Download Manager Translation Bug in Greek Language Pack

RESOLVED FIXED

Status

Mozilla Localizations
el / Greek
--
trivial
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Alexandros T, Assigned: Kostas Papadimas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; el; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; el; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

A translation bug exists in firefox 3.0 and 3.0.1

Reproducible: Always

Steps to Reproduce:
Note: You must have installed the Greek version of firefox:
1.Try to download a file from the web using thw download manager
2.Press the Pause button
Actual Results:  
The text under the progress bar is: "Paused - 722 KB από 9.1 MB" (example)

Expected Results:  
The text under the progress bar should be: "Παύση - 722 KB από 9.1 MB"

If you also point the mouse pointer on that text, the tooltip that appears has also the same incorrect text
(Reporter)

Comment 1

10 years ago
Created attachment 330040 [details]
A screenshot showing the problem
Assignee: nobody → pkst
Component: Download Manager → el-GR / Greek
Product: Firefox → Mozilla Localizations
QA Contact: download.manager → pkst
(Assignee)

Comment 2

10 years ago
Thanks Alexandre, 
Bug confirmed, I 'll try to fix it in next versions.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
(Reporter)

Comment 3

10 years ago
Kosta, I found out how to fix the bug.
You just have to unzip the el.jar file (firefox_directory/chrome/el.jar) and look for file el/mozapps/downloads/downloads.properties. In line #20, you will find:
paused=Paused —  #1
Just replace "Paused —  #1" with "Παύση —  #1" and done :)
(Assignee)

Comment 4

10 years ago
Yep.. This exact string has to be fixed on svn in this .properties file. The problem is that he svn tree is closed and I cannot commit any changes to it. 
(Reporter)

Comment 5

10 years ago
Similar translation bug found:
1.Right-click anywhere on a Web Page
2.Click "Προβολή πηγαίου κώδικα"
3.Click anywhere on the text block
4.If you look at the bottom of the window, you'll see that "Στήλ" should be replaced by "Στήλη".
(Reporter)

Comment 6

10 years ago
Created attachment 334445 [details]
A screenshot showing the second bug
(Assignee)

Comment 7

10 years ago
Thanks Alexandre, fixed in trunk (hg). Changes will be visible in Firefox 3.1 beta.
Marking bug as resolved> Fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.