Clicking Torbutton causes Firefox to crash with the following error (Torbutton Add-on)

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: badr dosari, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Avant Browser; FDM; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 1.1.4322; InfoPath.2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

You have to install Torbutton Add-on.
Clicking Torbutton causes Firefox to crash with the following error :

XML Parsing Error: undefined entity
Location: chrome://browser/content/browser.xul
Line Number 187, Column 5:
    <key id="key_errorConsole" key="&errorConsoleCmd.commandkey;" oncommand="toJavaScriptConsole();" modifiers="accel,shift"/>
----^


Reproducible: Always

Steps to Reproduce:
1. Install Torbutton Add-on.
2. Restart FireFox.
3. Click on Torbutton more than once.
Actual Results:  
FireFox crashed with the following error:

XML Parsing Error: undefined entity
Location: chrome://browser/content/browser.xul
Line Number 187, Column 5:
    <key id="key_errorConsole" key="&errorConsoleCmd.commandkey;" oncommand="toJavaScriptConsole();" modifiers="accel,shift"/>
----^



Firefox can only be restarted in Safe Mode, a normal restart results in the above error.

When I reset all user preferences. I can start FireFox in normal mode.
Please report this to the Torbutton extension developers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
Someone has reported it to them. But they said it could be a FireFox bug because Torbutton is just javascript and XML.
https://bugs.torproject.org/flyspray/index.php?do=details&id=746&area=comments#tabs
>Firefox can only be restarted in Safe Mode
The safemode is just Firefox without addons and third party Themes. That means that Firefox works and there is nothing to fix for us because this is an extension problem.

There could be a bug in Firefox that you see only with an extension but the developers of that extension can create a bug report and they must explain what they are doing. You can not expect us to investigate the whole extension code.

You need to log in before you can comment on or make changes to this bug.