FTP folder contents not displayed

RESOLVED DUPLICATE of bug 406787

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 406787
10 years ago
10 years ago

People

(Reporter: Jamie Calderwood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When clicking to go to different folders on ftp server firefox displays folder name at the top but does not display the contents of the folder. Will only work if linked directly to page.

Reproducible: Sometimes

Steps to Reproduce:
1.Go to a ftp server such as ftp://ftp.westwood.com
2. Navigate around
3. Click on folders containing files
Actual Results:  
Folder does not display anything.

Expected Results:  
Folder should show the files that it contains.

Tested on ftp://ftp.westwood.com with 2 different computers both with same bug.

Comment 1

10 years ago
I have been able to reproduce this on windows and linux platforms and with all Firefox 3 installations (RCx, 3.0, 3.01) I had: There is a severe bug concerning FTP access (perhaps it's the caching?). 

There are 2 error scenarios that are getting on my nerves (Firefox 2 didn't have those bugs!):

a) If you get an FTP error (for example 550) and click OK on the dialog box, everything is fine. You get an empty screen. 
But as soon as you reload, the screen changes, you don't get another time the failure message. Instead, an empty FTP folder is displayed

-------------------
Index of ftp://[...]

Up to higher level directory
Name 	Size 	Last Modified
-------------------


b) If you get an error (that could be resolved by retrying later), you have to force Firefox to reload (Ctrl-F5 works, F5 works after several key-presses) the ftp:// URL in order to let it see the true contents. If this happens with a file download, that becomes available after refreshing, the download starts, but is downloaded with the wrong filename (000000.part instead of the real one).

An example for a): You don't have a local ftp? Perfect. Go to ftp://localhost . This will get you an error. If you reload, you will get an empty folder listing. This is not what you expect. You should get nothing at all, a repetition of the same error message would be appropriate.

An example for b): This time I have my local ftp running. I go to ftp://localhost/thisfiledoesntexist.yet - Firefox gives me a error dialogue. I click OK, then click into the adressbar, then return. Firefox adds a "/" to the URL ftp://localhost/thisfiledoesntexist.yet/ and shows me

------------
Index of ftp://localhost/thisfiledoesntexist.yet/

Up to higher level directory
Name 	Size 	Last Modified
------------

If I now create a file called thisfiledoesntexist.yet and refresh Firefox with the URL ftp://localhost/thisfiledoesntexist.yet/ still in the adress bar, I am giving the prompt where to store "bWu5a5vx.bin.part". The filename IS LOST COMPLETELY. Instead, If I don't change anything, I will get a file with a totally cryptic name on the desktop that can't be opened correctly because the extension also changed! I have to enter manually that the file was named "thisfiledoesntexist.yet" on the save dialogue - for me a very annoying bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406787
You need to log in before you can comment on or make changes to this bug.