DEB install for N8x0 doesn't update correctly

VERIFIED FIXED in fennec1.0m6

Status

P2
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: mfinkle, Assigned: blassey)

Tracking

Trunk
fennec1.0m6
x86
Windows XP
Bug Flags:
blocking-xul-fennec1.0 +

Details

Attachments

(4 attachments)

I tried using the N810 Application Manager to "update" to Fennec 0.5 from Fennec 0.4, but it appears that only Fennec was updated. The previous version of XULRunner was left on the machine. I expected a dependency to updtae the XULRunner too.

In the end, I uninstalled Fennec 0.4 & XULRunner, then installed Fennec 0.5 (which installed XULRunner for me)

Updated

11 years ago
Flags: blocking-fennec1.0+
Priority: -- → P2
Target Milestone: --- → Fennec M6
Yeah, I had the exact same problem.

Updated

11 years ago
Duplicate of this bug: 445919
Assignee: nobody → blassey
Created attachment 331355 [details] [diff] [review]
adds the buildid to the version number of the xulrunner deb package
Created attachment 331356 [details] [diff] [review]
sets the xr dependency to the xr milestone+buildid
Attachment #331355 - Flags: review?(ted.mielczarek)
Attachment #331356 - Flags: review?(ted.mielczarek)
Comment on attachment 331355 [details] [diff] [review]
adds the buildid to the version number of the xulrunner deb package

+debian/changelog: $(srcdir)/debian/changelog.in 

You should make this:
+debian/changelog: $(srcdir)/debian/changelog.in  $(LIBXUL_DIST)/bin/platform.ini

So that it updates correctly when the milestone changes.

r=me with that change
Attachment #331355 - Flags: review?(ted.mielczarek) → review+
Attachment #331356 - Flags: review?(ted.mielczarek) → review+
Created attachment 331690 [details] [diff] [review]
removes changelog from makefiles.sh
Attachment #331690 - Flags: review?(ted.mielczarek)
Created attachment 331691 [details] [diff] [review]
removes control from makefiles.sh
Attachment #331691 - Flags: review?(ted.mielczarek)
Attachment #331690 - Flags: review?(ted.mielczarek) → review+
Attachment #331691 - Flags: review?(ted.mielczarek) → review+

Comment 8

11 years ago
brad landed his fix
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
verfied with beta3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.