Closed Bug 445919 Opened 13 years ago Closed 13 years ago

Launching Fennec from Extras > Fennec shortcut fails

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 445918

People

(Reporter: mfinkle, Unassigned)

Details

For some reason, after installing Fennec 0.5, I am unable to correctly launch Fennec from the Extras > Fennec shortcut.

Fennec attempts to launch, but for some reason an incorrect version of XULRunner is being used. The bad XULRunner does not have modules/SpatialNavigation.js and therefore Fennec aborts with a XPCOM error (file not found) in browser.js

The same thing happens if I attempt to run Fennec from the terminal window using the "fennec" stub (which should be the correct way to launch).

If I use | /usr/local/xulrunner/xulrunner /usr/local/fennec/application.ini | Fennec will launch correctly.
is this a dup of 445918?
Nope, unrelated.  You have to get the new xulrunner for it to even start but even with the new xulrunner you still have to start it from the command line.
Actually, scratch that.  I am able to launch it from the Extras menu now.  Weird.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 445918
verfied with beta3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.