mouse pointer interacting with some flash banners behind semi-transparent dropdown menus in mac os-x 10.5.4

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: onlinebayarea, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

I recently upgraded to mac os-x 10.5.4, and noticed that when a dropdown menu was open and the pointer passed over a banner ad with an interactive flash animation behind the menu, it would behave as if the menu was not there.  

With certain banners, the pointer is not displayed while on top of the banner; when a menu is open, it disappears when it passes over the flash banner and doesn't reappear until clicking somewhere to close the menu.  The pointer remains hidden when passing between menus, and when not over a menu.  This happens with both live bookmarks and the top menu bar.

Reproducible: Always

Steps to Reproduce:
1. Go to sfgate.com/news/ or another site with banner ads near the top of the page.
2. Reload until a flash ad appears that hides the pointer and includes an animation that follows the pointer; specifically the comcast ads.
3. Open a live bookmark that covers the banner, and pass the pointer over an item on top of the banner.
Actual Results:  
The flash animation responds to the pointer, which disappears when passing over the banner, and does not reappear when moved away from the banner.

Expected Results:  
The pointer should not disappear.

I never noticed this problem in the previous version of the OS.

Comment 1

9 years ago
This looks like the bug I just saw, I think I have a better example:

http://www.mountpakenham.com/

Bookmark (click star), then click star again and move the mouse down into the popup, over the flash animation.  The pointer will be visible, but behind the popup!

Then also open the bookmarks menu and move the mouse down.  When it reaches the point where the flash animation starts (behind the menu) it will disappear.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

9 years ago
I should point out: I experienced the above both with Fx 3.0.5 as well as yesterday's 3.1 nightly.  Both on the latest OS X.

Comment 3

9 years ago
This seems to be a general issue with mouse tracking on OSX in general. For instance, if a user were hovering over the dock while Firefox is displayed behind it Firefox will continue tracking the mouse despite the fact that the dock is on top and focused.

Good examples are title tag tooltips on html elements and the above flash example where the cursor is hidden by flash.

Screenshot of flash / dock issue here: http://sholsinger.com/files/bugs/ff/bug_445920_dock.png
Also, it seems that the "grab" utility in Mac OS X doesn't include the mouse pointer. So right about where the "hand" cursor is in that screen capture is the normal OS X mouse cursor.
Over the years and many OS and firefox updates later, this issue appears to have resolved itself.

If you find this observation to be in error, please reopen the issue! I'd appreciate a few steps to reproduce in that case.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.