Cannot add excpetion for a self-signed certificate




10 years ago
7 years ago


(Reporter: Marcin Raczkowski, Unassigned)


Firefox Tracking Flags

(Not tracked)



(1 obsolete attachment)



10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv: Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv: Gecko/2008070208 Firefox/3.0.1

After trying several methods to get VMWare http console to work, I STILL get only alert that says "sec_error_untrusted_issuer".
I get only alert nothing more, no option to override.
I changed browser.xul.error_pages.expert_bad_cert and few other options that were suggested.
I tried to manually add exception, and even while trying to add it i get this f!#!$%!$! alert, there's simply no way to ovveride it, i don't have this problem on debian, i guess they sanitized this stupid policy, but why oh why when i KNOW that it's machine in my own office, i have to pay $100 for cert?

Reproducible: Always

Steps to Reproduce:
1. Use newest VMWare web console (free)
2. try to access it via https
Actual Results:  
compleate impossibility to add exception for self-signed cert

Expected Results:  
I have no problem browsing throught several menus, writing manualy "Yes I'm sure i want to use self-signed cert" but i should be able to add exception.

Comment 1

10 years ago
Created attachment 330195 [details]
Attacment of my try to add exception for self-signed cert

Comment 2

10 years ago
you can check this by trying to open

Comment 3

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2008070208 Firefox/3.0.1

works for me, using the default settings (I can see the VMWare login page). Did you change anything other than browser.xul.error_pages.expert_bad_cert ?
Be sure that browser.xul.error_pages.enabled is true and that you don't use a proxy on localhost.

Comment 5

10 years ago
I tried browser.xul.error_pages.enabled before, and i rechecked again.

no idea why it doesn't work, now i checked from another account on same system, and it alows me to add an exception.

I think it's just some strange mixture of things


10 years ago
Attachment #330195 - Attachment is obsolete: true
Resolving unconfirmed bugs older than a year with no activity as INCOMPLETE.  Please reopen or file a new bug if you can still reproduce the bug.
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.