If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multiple browser windows don't navigate properly

VERIFIED FIXED in M5

Status

SeaMonkey
UI Design
P2
major
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: steve.beitzel, Assigned: davidm)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Steps to reproduce:
1. Launch apprunner.exe
2. In the browser window's address field, enter a URL.
(Say, http://www.mozilla.org)
3. Open a new browser window.
4. In the new window's address field, type a different URL.
(Say, http://www.yahoo.com)
5. Observe that the first window comes to the foreground and its content updates
to be that of the page specified by the second URL.

Build/System information:
Windows NT 4, service pack 3
Build ID 99032914
VC 6

Updated

19 years ago
Assignee: rickg → don
Severity: normal → major
Component: Viewer App → Apprunner
Priority: P3 → P2
QA Contact: 3853 → 3819

Comment 1

19 years ago
Yes.  See this with Win95 also.  Assigning to don to figure out who gets this.

Updated

19 years ago
Assignee: don → davidm
Component: Apprunner → XPApps
Target Milestone: M5

Comment 2

19 years ago
Re-assigned to davidm@netscape.com, changed component to XPApps, and set target
milestone to M5.

David, is this "Window Manager" -type work?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
assign.  This really shouldn't have anything do to with window management but
I'll investigate when I get a build that can load URL's again.
(Assignee)

Comment 4

19 years ago
This is happening because all browser windows are sharing the same appcore. I am
told that the the XPtoolkit team will be fixing this for m5.
(Assignee)

Comment 5

19 years ago
*** Bug 4466 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
marking fixed in the 4/19 build now that each window is getting its own appcore.
There appears to be a problem where the throbber activates in both windows but I
think it deserves its own bug.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
verified fixed in 5/12 builds. I don't see the throbber problem either.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.