bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.


mozilla.org Graveyard
Server Operations
10 years ago
3 years ago


(Reporter: fligtar, Assigned: xb95)





10 years ago
amo-developers@mozilla.org hasn't been getting cron emails from download counting scripts since 7/11.

I got one on 7/14, but that's the only one since 7/11. I've got yesterday's updateping cron but not downloads.


10 years ago
Assignee: server-ops → oremj

Comment 1

10 years ago
I see e-mails going out.  The last I saw was July 20, 2008 6:00:04 PM PDT.  Not seeing it?

Comment 2

10 years ago
I have them from 7/19 and 7/20, so it might be working again. I'll re-open if it skips another day.
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 3

10 years ago
Haven't received any new cron emails since 7/20.

If IT has received them, can you forward them to amo-developers? Have had a report of statistics issues that I can't verify.
Resolution: WORKSFORME → ---

Comment 4

10 years ago
See this in the maillog:

Jul 20 20:47:16 dm-stats01 sendmail[10273]: m6L3lGHw010272: to=<amo-developers@mozilla.org>,sysalerts@mozilla.org, ctladdr=<root@dm-stats01.mozilla.org> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=239204, relay=mail.mozilla.org. [], dsn=2.0.0, stat=Sent (Ok: queued as 0653E12914A)
Jul 21 22:53:40 dm-stats01 sendmail[4619]: m6M104Ag004619: to=amo-developers@mozilla.org,root, ctladdr=root (0/0), delay=04:53:36, xdelay=00:01:29, mailer=relay, pri=206280202, relay=[] [], dsn=2.0.0, stat=Sent (m6M5qBLR024678 Message accepted for delivery)
Jul 21 22:53:40 dm-stats01 sendmail[24695]: m6M5qBLR024678: to=<amo-developers@mozilla.org>,sysalerts@mozilla.org, ctladdr=<root@dm-stats01.mozilla.org> (0/0), delay=00:01:29, xdelay=00:00:00, mailer=esmtp, pri=206280685, relay=mail.mozilla.org. [], dsn=5.0.0, stat=Service unavailable
Jul 23 05:33:16 dm-stats01 sendmail[7638]: m6N104Bd007638: to=amo-developers@mozilla.org,root, ctladdr=root (0/0), delay=11:33:12, xdelay=00:01:48, mailer=relay, pri=1569560262, relay=[] [], dsn=2.0.0, stat=Sent (m6NCVSuv023578 Message accepted for delivery)
Jul 23 05:33:16 dm-stats01 sendmail[23583]: m6NCVSuv023578: to=<amo-developers@mozilla.org>,sysalerts@mozilla.org, ctladdr=<root@dm-stats01.mozilla.org> (0/0), delay=00:01:48, xdelay=00:00:00, mailer=esmtp, pri=1569560745, relay=mail.mozilla.org. [], dsn=5.0.0, stat=Service unavailable
Jul 24 10:11:45 dm-stats01 sendmail[7859]: m6O102fD007859: to=amo-developers@mozilla.org,root, ctladdr=root (0/0), delay=16:11:43, xdelay=00:03:37, mailer=relay, pri=2810302040, relay=[] [], dsn=2.0.0, stat=Sent (m6OH89Wc006964 Message accepted for delivery)
Jul 24 10:12:04 dm-stats01 sendmail[7052]: m6OH89Wc006964: to=<amo-developers@mozilla.org>,sysalerts@mozilla.org, ctladdr=<root@dm-stats01.mozilla.org> (0/0), delay=00:03:55, xdelay=00:00:01, mailer=esmtp, pri=2810302523, relay=mail.mozilla.org. [], dsn=5.0.0, stat=Service unavailable

Dave, do you know what could be happening here?
Assignee: oremj → justdave
oh, dm-stats01 is what's sending this?

I know exactly what the problem is.

/me rifles though his trash folder for the bounce notice he deleted a couple hours ago...

ah, here it is:


   ----- The following addresses had permanent fatal errors -----
    (reason: 552 Message size exceeds file system imposed limit)
    (expanded from: <root@dm-stats01.mozilla.org>)
    (reason: 552 Message size exceeds file system imposed limit)

   ----- Transcript of session follows -----
... while talking to mail.mozilla.org.:
>>> MAIL From:<root@dm-stats01.mozilla.org> SIZE=2810242523
<<< 552 Message size exceeds file system imposed limit
554 5.0.0 Service unavailable


WTF are you trying to send a 2.8 GB email for? :)

Comment 6

10 years ago
Justin, can you modify your script to print a little less data?  If you need all the content we can just send the output to a file and copy it over to khan or something.

Comment 7

10 years ago
The previous cron emails were around 150KB. If you have a sample output of a 2.5GB file I'd love to see what it started outputting with no code changes.
We'll have to fix it to write to disk to get the output, since the mail server is basically discarding it as too big to deal with. (the bounce notice truncated the body after the headers)

Comment 9

10 years ago
Ok, can we do that by the time the script runs tomorrow (if it wasn't done for tonight?).

I'm worried the log is full of MySQL errors which is creating the size and causing most of our downloads to be off (bug 447869).
Assignee: justdave → oremj

Comment 10

10 years ago
Set up: /usr/local/bin/addons_stats_downloads.sh > /root/download_stats
2>&1; gzip /root/download_stats; 

The file will be ready for you tomorrow.

Comment 11

10 years ago
The output from last night was only 248K.

Comment 12

10 years ago
Put the file in khan:/home/fligtar/download_stats.gz

Comment 13

10 years ago
khan has a gig of free space and can't gunzip, worst ever!

Comment 14

10 years ago
Do we have a bug tracking the actual problem?

Comment 15

10 years ago
Mark, see Comment 14.


10 years ago
Assignee: oremj → mark

Comment 16

10 years ago
(In reply to comment #14)
> Do we have a bug tracking the actual problem?

I guess it's bug 449731.

Comment 17

10 years ago
The other bug was resolved, so this is resolved, I believe.  Let me know if I'm wrong!
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.