Thunderbird's "Delete" button can delete an event or a task

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: benc, Unassigned)

Tracking

Lightning 0.8
PowerPC
Mac OS X

Details

(Reporter)

Description

11 years ago
Originally found on Solaris versions, but more usefully, confirmed on Mac OS X builds. I did a dupe check before filing, Bug 359443 seemed similar (same problem, but backwards)

Thunderbird 2.0.0.14 (release)
Lightening 0.8 (build 2008033121)

STEPS:

(background: the "Delete" button is only enabled when a message is selected in the   message list).

Click on a message.
Click on a Task in the "Today" pane.
Click on "Delete"

EXPECTED:
The selected message should be deleted.

OBSERVED:
The selected task is deleted, the message remains.

Comments:
I looked around to see if there were any wiki pages or design documents that talked about the toolbar buttons and scope of action.

My personal thinking is that all those buttons are for mail, they shouldn't be running off and sending events to the add-ons, at least not at the current level of design.
I think that's the desired behavior. If you are in Mail Mode and the focus is set to Today Pane you can use the Delete toolbar button to delete entries in it. See e.g. Bug 195580 and Bug 413474 that were fixed for Lightning 0.8.

Comment 2

11 years ago
I agree with ssitter, this is the desired behaviour especially as it's clear in the gui that the message isn't the main selection anymore (it becomes light-gray).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
Are you speaking from the perspective of a Lightning developer or a Thunderbird developer?

There are many buttons in that toolbar, almost none of them have any relevance to the Lightning functionality. 

Comment 4

11 years ago
(In reply to comment #3)
> Are you speaking from the perspective of a Lightning developer or a Thunderbird
> developer?
> 

Please focus on what is important from an users point of view. Users do not care about implementation details. For them it is one product.
The delete button behavior works from an users point of as expected.

> There are many buttons in that toolbar, almost none of them have any relevance
> to the Lightning functionality. 
> 

(Reporter)

Comment 5

11 years ago
Christian: 

I am talking about this problem from both the perspective of a user and then looking at the underlying design issues.

As a user, I deleted several events before I realized that I was not deleting mail.

And, in filing this bug, I think the line of questioning is very valid. From a Thunderbird perspective, do we want toolbar buttons to apply to all selectable elements? Does this make sense since the toolbar is originally designed to provide functionality to the core Thunderbird UI.

As I an extension developer, I would want to be able to leverage the UI, but that may not be the perspective that should hold.

Assuming we take the second perspective, should there be additional context to how the delete event is applied to targets? For example, the mailbox deletion has a confirmation dialog. I think this is very good design, for obvious reasons. I think a similar consideration should be made for the situation I am describing.

Christian: 

"Users do not care about implementation details. For them it is one product."

Thunderbird is a product. Lightning is an extension.

And if you are talking about merging the two into one product, you must be very careful about the context of which UI elements work between components. This was one of the problems that made Netscape/Mozilla/Seamonkey too top heavy, and ultimately replaced by the product strategy we have today. 

I'm sorry I missed the bugs when I searched before, but in bug 413474, the very first comment says:

"...I foresee people accidentally deleting an event
or task when they meant to delete an email."

And even now, undo doesn't work, bug 398405. So, yeah, the details matter, this isn't implemented seamlessly.
You need to log in before you can comment on or make changes to this bug.