bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

HTTP errors are not passed to the user

VERIFIED DUPLICATE of bug 306495

Status

Calendar
Provider: CalDAV
--
minor
VERIFIED DUPLICATE of bug 306495
10 years ago
10 years ago

People

(Reporter: Andrew Daviel, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-GB; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Gecko/20080717 Calendar/0.9pre

e.g. Bedework server 3.4.1.1 :
PROPFIND /ucaldav/user/advax/test2 HTTP/1.1
Accept: text/xml
..
HTTP/1.1 404 /user/advax/test2
Content-Type: text/html;charset=utf-8
..
...The requested resource (/user/advax/test2) is not available...

generates a popup box in Sunbird with
Error number: MODIFICATION_FAILED. Description: 

(arguably Bedework should return an XML message not an HTML one)

Reproducible: Always

Steps to Reproduce:
1. Specify a non-existant CalDAV calendar in Sunbird
2. Connect to it
3. Create an event
Actual Results:  
Error number: MODIFICATION_FAILED. Description:

Expected Results:  
HTTP Error: PROPFIND status 404 Not Found.
Description: The calendar http://cal.example.com/ucal/user/joe cannot be found

Comment 1

10 years ago
IMO we need to special-case 404 errors and it's not clear that the CalDAV provider should be reporting them: they are perhaps more likely due to a (temporary) network-not-there condition than anything else. We should catch and deal with 404s during calendar creation, but I think that once a CalDAV calendar has been registered 404s should probably simply disable it under the assumption that the network (and remote calendar store) will at some point be back.
network not there shouldn't trigger a 404. I think most of this bug can be "fixed" by using webdav discovery to find the needed calendar resources in bug 306495. If the location provided triggers a 404, then the auto-detect code should notify the user in some way. I'm going to dupe this bug against bug 306495 and comment there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 306495
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.