Last Comment Bug 446129 - Contact sidebar blanks if email only
: Contact sidebar blanks if email only
Status: VERIFIED FIXED
[fixed by bug 451021]
:
Product: Thunderbird
Classification: Client Software
Component: Address Book (show other bugs)
: Trunk
: All Mac OS X
: -- normal with 1 vote (vote)
: Thunderbird 3
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 451021
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-18 17:36 PDT by Mitra Ardron
Modified: 2008-08-19 22:52 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Vcard for a person who shows up blank in contacts sidebar (215 bytes, text/x-vcard)
2008-08-14 23:19 PDT, Mitra Ardron
no flags Details

Description Mitra Ardron 2008-07-18 17:36:21 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: version 3.0a2pre (2008071803)

If an OSX Address book entry contains just as an email address, then when you display the Contacts Sidebar it just shows a blank entry.

Reproducible: Always

Steps to Reproduce:
1. Enter a new card in OSX Address book, 
2. Just enter email address
3. Shredder -> New Message
4. View Contacts Pane

Actual Results:  
New entry appears at the top as a blank item

Expected Results:  
New entry appears as the email address, in order

This might sound like an odd occurance, but it can happen on OSX Address book when something else imports email addresses into it which have no name. 

In OSX Address book these are treated well - they show up as the email address which is often where you are going to search for them if you know the name.
Comment 1 Wayne Mery (:wsmwk, NI for questions) 2008-08-13 03:01:10 PDT
Henrik, do you see this too?
Comment 2 Henrik Skupin (:whimboo) 2008-08-13 14:15:11 PDT
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080813030132 Shredder/3.0b1pre ID:20080813030132

No, I don't see this. I've also an empty card as the first item within the contacts sidebar, but this isn't the new created address book card. When I scroll down I can find the new card, which has the first part (before the @) of the email address as name. Mitras, can you please re-check? Which version of Shredder you are using?
Comment 3 Mitra Ardron 2008-08-14 19:50:22 PDT
Yes - its still there,  I'm using 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080813030132 Shredder/3.0b1pre

Note to make this work you have to add an item in the OSX address book, and not put in anything except hte email address (it sounds obscure, but it happens with email lists)
Comment 4 Henrik Skupin (:whimboo) 2008-08-14 23:10:26 PDT
That's what I did. And the name will be shown correctly. What do you mean with email lists?
Comment 5 Mitra Ardron 2008-08-14 23:18:59 PDT
By Email lists, I meant that I have a number of these blank cards, imported from elsewhere, they are then in a OSX Address Book "Group", with the intent that an email can be sent to the entire list. 

I'll attached a vcard for one of these people - this person shows up blank in the "Contacts" list. 
Comment 6 Mitra Ardron 2008-08-14 23:19:53 PDT
Created attachment 333898 [details]
Vcard for a person who shows up blank in contacts sidebar
Comment 7 Henrik Skupin (:whimboo) 2008-08-15 10:19:08 PDT
I imported the vcard into the OS X address book and started Shredder afterwards. When opening the message compose window the contacts sidebar shows me "aaa" as the name of the card entry. Mitra, I'm still not able to reproduce your problem. It's a bit strange because we are using the same version of OS X and Shredder.
Comment 8 Mitra Ardron 2008-08-15 16:04:07 PDT
OK - I wonder if there is some obscure preference? I've tried the one Advanced / General /  "Display Names" and that doesn't seem to make a difference.

Has anyone else tried to repeat it - would be good to know if its just an oddity on my machine or if its common. 


Comment 9 Henrik Skupin (:whimboo) 2008-08-16 07:03:02 PDT
Mitra, one way to find this out is to create a new profile. Starting with blank data could give you a good starting point. If it works that way try to check the differences between both profiles.
Comment 10 Mitra Ardron 2008-08-16 17:27:47 PDT
Sorry, what I men is that I've no idea how to go about creating a new profile (without of course losing my exisiting email).
Comment 11 Henrik Skupin (:whimboo) 2008-08-17 13:53:55 PDT
See bug 439142 comment 17.
Comment 12 Mark Banner (:standard8) 2008-08-18 10:02:23 PDT
So I can probably reproduce this:

1) Open address book, View -> Show Name As -> Display Name
2) Open write/compose and look at contacts
- no name is displayed

1) Open address book, View -> Show Name As -> First, Last (or Last, First)
2) Open write/compose and look at contacts
- Uses first/last name.

I could have sworn this was a duplicate of another bug.
Comment 13 Henrik Skupin (:whimboo) 2008-08-19 13:49:51 PDT
Mitra, is this bug fixed for you now? Please run a test with the latest trunk nightly build. Thanks.
Comment 14 Henrik Skupin (:whimboo) 2008-08-19 14:15:18 PDT
Mitras, after a talk with Mark this should have been fixed by his patch on bug 451021. Please try and if it is still happen feel free to reopen.
Comment 15 Mitra Ardron 2008-08-19 22:50:51 PDT
Thanks - confirmed fixed.

- Mitra

Note You need to log in before you can comment on or make changes to this bug.