Contact sidebar blanks if email only

VERIFIED FIXED in Thunderbird 3

Status

Thunderbird
Address Book
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Mitra Ardron, Unassigned)

Tracking

Trunk
Thunderbird 3
All
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 451021])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: version 3.0a2pre (2008071803)

If an OSX Address book entry contains just as an email address, then when you display the Contacts Sidebar it just shows a blank entry.

Reproducible: Always

Steps to Reproduce:
1. Enter a new card in OSX Address book, 
2. Just enter email address
3. Shredder -> New Message
4. View Contacts Pane

Actual Results:  
New entry appears at the top as a blank item

Expected Results:  
New entry appears as the email address, in order

This might sound like an odd occurance, but it can happen on OSX Address book when something else imports email addresses into it which have no name. 

In OSX Address book these are treated well - they show up as the email address which is often where you are going to search for them if you know the name.
Henrik, do you see this too?
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080813030132 Shredder/3.0b1pre ID:20080813030132

No, I don't see this. I've also an empty card as the first item within the contacts sidebar, but this isn't the new created address book card. When I scroll down I can find the new card, which has the first part (before the @) of the email address as name. Mitras, can you please re-check? Which version of Shredder you are using?
Hardware: Macintosh → All
Version: unspecified → Trunk
(Reporter)

Comment 3

9 years ago
Yes - its still there,  I'm using 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080813030132 Shredder/3.0b1pre

Note to make this work you have to add an item in the OSX address book, and not put in anything except hte email address (it sounds obscure, but it happens with email lists)
That's what I did. And the name will be shown correctly. What do you mean with email lists?
(Reporter)

Comment 5

9 years ago
By Email lists, I meant that I have a number of these blank cards, imported from elsewhere, they are then in a OSX Address Book "Group", with the intent that an email can be sent to the entire list. 

I'll attached a vcard for one of these people - this person shows up blank in the "Contacts" list. 
(Reporter)

Comment 6

9 years ago
Created attachment 333898 [details]
Vcard for a person who shows up blank in contacts sidebar
I imported the vcard into the OS X address book and started Shredder afterwards. When opening the message compose window the contacts sidebar shows me "aaa" as the name of the card entry. Mitra, I'm still not able to reproduce your problem. It's a bit strange because we are using the same version of OS X and Shredder.
(Reporter)

Comment 8

9 years ago
OK - I wonder if there is some obscure preference? I've tried the one Advanced / General /  "Display Names" and that doesn't seem to make a difference.

Has anyone else tried to repeat it - would be good to know if its just an oddity on my machine or if its common. 


Mitra, one way to find this out is to create a new profile. Starting with blank data could give you a good starting point. If it works that way try to check the differences between both profiles.
(Reporter)

Comment 10

9 years ago
Sorry, what I men is that I've no idea how to go about creating a new profile (without of course losing my exisiting email).
See bug 439142 comment 17.
So I can probably reproduce this:

1) Open address book, View -> Show Name As -> Display Name
2) Open write/compose and look at contacts
- no name is displayed

1) Open address book, View -> Show Name As -> First, Last (or Last, First)
2) Open write/compose and look at contacts
- Uses first/last name.

I could have sworn this was a duplicate of another bug.
Mitra, is this bug fixed for you now? Please run a test with the latest trunk nightly build. Thanks.
Mitras, after a talk with Mark this should have been fixed by his patch on bug 451021. Please try and if it is still happen feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Depends on: 451021
Resolution: --- → FIXED
Whiteboard: [fixed by bug 451021]
Target Milestone: --- → Thunderbird 3
(Reporter)

Comment 15

9 years ago
Thanks - confirmed fixed.

- Mitra
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.