VPN connectivity causing unusable session

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
8 years ago

People

(Reporter: le.adamlane, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-12-01])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

While having any session open in Firefox, then connecting to a standard VPN that pushes it's gateway down on your connection causes Firefox to not be able to connect to anything until restarted. Understandable, but should have a "smart re-connect" or something.

Reproducible: Always

Steps to Reproduce:
1. Use Firefox as per normal
2. Use Windows (re-produced in Vista on my end) to connect to a vpn
3. Attempt to continue using Firefox
Actual Results:  
No connectivity.

Expected Results:  
Firefox to "figure out" that it can still connect to the internet, just not using the current connection sessions it is using, then repair.
How about file/work offline and then file/work offline again ?

Comment 2

10 years ago
My problem is similar. I work for Oracle and use the corporate VPN because I work from home. 

1. When starting the browser after the VPN is connected, everything works fine
2. Everything continues to work fine when the VPN drops or is shut down
3. However, when leaving a browser open and restarting the VPN, Firefox cannot resolve any URL's and eventually times out.
4. To kick-start Firefox (instead of shutting it down and re-launching it) I open "Tools - Options - Network - Settings" and click "reload" for "Automatic Proxy Configuration URL"

Having to work through the options menu and clicking reload is a pain in the bum. It would be nice if Firefox automatically detected network changes and automatically reloaded the proxy. Alternatively, a wee button somewhere that I could click without having to open the options menu would be a useful work-around.

Comment 3

10 years ago
Duplicate bug:  465336

and 284152 (probably)

and http://www.neowin.net/forum/index.php?showtopic=769282

Comment 4

10 years ago
And I should add that I experience this bug on WinXP, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 GTB5

Easy to reproduce. Disconnect a VPN and then try browsing anywhere.
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Whiteboard: [CLOSEME 2010-12-01]
(Reporter)

Comment 6

8 years ago
I no longer have access to a Windows machine and cannot replicate this on OS X, and since no one has updated this in so long I guess we should mark as resolved
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.