Firefox updated pop-up appear even with "ask me before update" checked but there is no update effective

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
--
minor
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: pascal scholtes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9) Gecko/2008052906 Firefox/3.0

There was a message pop-up (right-down of the screen) "firefox 3.0.1 downloaded and installed", but in options -> advances -> update, under firefox: "ask me" is checked !!??

After that, It never ask me for restart firefox, who is usual after a real update.
So there is no effective update !

I am not sure but I think that from this time there will be no more update to 3.0.1

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.



I don't no how to reproduce it !
I use the default theme.
I think the wording is just wrong.
I think Firefox dowwnloaded the update but didn't install it.
What is help/check for updates doing ?
That would be the notification that an update is available via the alert service. To download and apply the update you could have clicked the notification or you can click Help -> Check for Updates. IMO the current notification system leaves a lot to be desired and might be improved via something like bug 347585.

Does selecting Help -> Check for Updates notify you that an update is available and allow you to download / install the update?
(Reporter)

Comment 3

10 years ago
I am not sure that  is just wrong wording.

The first pop-up appear in English (describe above) and few day after a pop-up appear in French, who seem to be  normal because its French software version, but the meaning is different in  french : " une  nouvelle version de firefox est prête à etre téléchargée et installée", that we can translate to : " a new firefox version is ready to be downloaded and installed", at this point we can think its just wrong wording but when I have try help/check for update, It return the following message ( English translation) :


problems were encountered during checking, of the remote loading or installation of this update. Firefox n' could not be updated following:

AUS : XML file bad consistency (200)


So he have try to download and install update without my permission ?! But It fail.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 4

8 years ago
pascal writes "I have tried to reproduce this error but I never can do again, I think this problem was on firefox 3.0 version but now I use Firefox 3.6 version without errors."

=> WFM per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 5

6 years ago
Your "bug" comment system is a bit confusing.  I just want to send you this msg and now I get all these other msgs.

Comment 6

6 years ago
Well, after I rebooted Firefox, the disabled "Java" add-0ns" became active again.  It appears all is ok.  I might add that Firefox should inform users of what to expect on upgrades and how to enable them.   I wasted a lot of time worrying about my disabled add-0n's for nothing.
You need to log in before you can comment on or make changes to this bug.