Password manager fails to save passwords from a login input box

RESOLVED DUPLICATE of bug 387652

Status

()

Toolkit
Password Manager
--
critical
RESOLVED DUPLICATE of bug 387652
10 years ago
10 years ago

People

(Reporter: Manlio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

I tried to view the telescopes data pages on my site: very data page contains about 24 images which has been placed in a protected directory (by apache, with httpd.conf and .htaccess); when you try to view them, correctly it shows an input box where you have to fill username and password. When I insert for the first time the correct username and password, it requests them another time, for about 24 times... Images has been placed ALL in the same directory, so it's very strange that it doesn't work after the first time.
The password manager has been shown by firefox after 24 times... (every time I had to digit username and password in the boxes) but it doesn't work: it saves the right username and password, but if I restart firefox the problem is present again (but this time each inputbox contains username and password field filled correctly) and I have to click on OK button 24 times...
With Firefox 2 I hadn't this problem, please correct it.

Sometimes firefox crashes causing me to lose data.

Thank you for your work

Manlio

Reproducible: Always

Steps to Reproduce:
1.Open the page
2.
3.
Actual Results:  
I tried to view the telescopes data pages on my site: very data page contains about 24 images which has been placed in a protected directory (by apache, with httpd.conf and .htaccess); when you try to view them, correctly it shows an input box where you have to fill username and password. When I insert for the first time the correct username and password, it requests them another time, for about 24 times (one for each loading image)... Images has been placed ALL in the same directory, so it's very strange that it doesn't work after the first time.
The password manager has been shown by firefox after 24 times... (every time I had to digit username and password in the boxes) but it doesn't work: it saves the right username and password, but if I restart firefox the problem is present again (but this time each inputbox contains username and password field filled correctly) and I have to click on OK button 24 times...

Expected Results:  
With firefox 2 I just fill only one time the input box and I check "Save this password" and it works properly every time, even if I restart firefox and for all successive logins.

I am using a default theme. This problem is not present in older firefox and I tested Safari and Internet Explorer too: only firefox 3 is affected by this. I think the problem is that it doesn't save the password during the images loading process and at the end of the process, the password manager is not able to manage the 24 passwords (but they are all equals: it shouldn't have to manage 24 password, but the first one correctly) and I think it saves just the first one or the last one (but just ONE).
(Reporter)

Comment 1

10 years ago
This problem is present in every web page where there are images which has been placed in a different directory protected with .htaccess and with httpd.conf configuration in apache.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387652
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.