Target="_top" not supported in Iframe

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Daniel Haagens, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)

If the window is narrowed, the Form in the Iframe is polluted. Netscape 7.2 handles this properly 

Reproducible: Always

Steps to Reproduce:
1.Narrow the window  a lot
2.
3.
Actual Results:  
windows get mixed up

Expected Results:  
form window should stay on top

Attaching screenshots of FF and Netscape 7.2
(Reporter)

Comment 1

10 years ago
Created attachment 330390 [details]
Screenshot of problem

Screenshot of Netscape 7.2 is in same folder D:\temp\nsshot.jpg
(Reporter)

Comment 2

10 years ago
Created attachment 330391 [details]
Netscape screenshot

Comment 3

10 years ago
Links and form can make use of target attribute; not iframe:
http://www.w3.org/TR/html4/present/frames.html#edef-IFRAME

The overlapping behavior issue may be caused by something else and has no relevance to target.

The <iframe> is declared first in the source code before the rest of the content appearing on the left. So, it looks normal and reasonable that there is an overlap from the rest of the content when browser window viewport is narrower. I checked with 3 other browsers (Internet Explorer 7, Opera 9.51, Safari 3.1.2) and this is also what they do (the form gets under the rest of content).

I'm afraid this behavior is normal and that NS 7.2 is wrong.

-----------

On an entirely different topic, the 3 framed and frameset webpages could use an upgrade.

The markup code in all 3 framed and frameset-ed webpages is very "tag-soup", relying on deprecated attributes, using incorrect doctype declaration and with dozens and dozens of validation markup errors.

If you want to upgrade your webpage code, then I suggest

Using Web Standards in your Web Pages
http://developer.mozilla.org/en/docs/Using_Web_Standards_in_your_Web_Pages

Web Authoring FAQ
http://www.htmlhelp.com/faq/html/

and you may seek assistance, support in web authoring forum discussion such as

alt.html
( http://groups.google.com/group/alt.html )

or

comp.infosystems.www.authoring.html
( http://groups.google.com/group/comp.infosystems.www.authoring.html )

or

MozillaZine Web development , web standards
http://forums.mozillazine.org/viewforum.php?f=25

Good luck,

Gérard

Comment 4

10 years ago
target and target="_top" have nothing, absolutely nothing to do with stacking levels and stacking order or z-index-ing of elements of a webpages.
As far as I can see, the overlapping of the iframed form when browser window viewport is narrower is the normal behavior here.

Resolving as INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.