Drag & Drop bookmark into specific position of nested bookmark folder submenu fails if submenu opens to the left

RESOLVED DUPLICATE of bug 419911

Status

()

RESOLVED DUPLICATE of bug 419911
10 years ago
10 years ago

People

(Reporter: bugzilla2007, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

With bookmark folders on the very right of bookmark toolbar, nested subfolders of such folders, when hovered over, will pop up to the left if there is not enough screen space for the pop-up on the right. The attempt to create a new bookmark by dragging a link into a specific position of the nested submenu fails (whereas this works perfectly whith menus that pop up to the right).


Reproducible: Always

Steps to Reproduce:
1. bookmark toolbar filled up with bookmarks, and a bookmark folder (e.g. myfolder_1) with (nested) subfolders on the very right of the toolbar;
2. the subfolder (e.g. mysubfolder_1) contains several bookmarks (e.g. bookmark1, bookmark2, bookmark3)
3. try to create a new bookmark positioned after bookmark2 in mysubfolder_1 by dragging and dropping a link there

Actual Results:  
On drag-hovering, the submenu for mysubfolder_1 opens correctly to the left(!), but it disappears as soon as you try hovering/dragging the new bookmark into a specific position on mysubfolder_1 no matter how slowly or precisely you do the dragging


Expected Results:  
The submenu for mysubfolder_1 should stay open on dragging over so that I can drop my new bookmark at the correct position (after bookmark2 in mysubfolder_1), which will be indicated by blue insertion line (which works fine as long as the submenu pops up to the right(!))


QA check needed - I can't believe this has not been reported before but I couldn't find anything.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419911
You need to log in before you can comment on or make changes to this bug.