Crash because of memory access error during play try of Real media files

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Markus Elfring, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-06-26, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.1) Gecko/2008070400 SUSE/3.0.1-1.1 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.1) Gecko/2008070400 SUSE/3.0.1-1.1 Firefox/3.0.1

I would like to listen to some music examples from the album "Tägliche Landschaft" of the group "Ruben Cossani". Unfortunately, all open firefox  windows vanish if I click on links in the section "Hörbeispiele".
(I assume that a SIGSEGV error was triggered.)

I can listen to the referenced RM files if I try the same with applications like the following on my openSUSE 11.0 system.
- SeaMonkey 1.1.11
- xine plug-in of Opera 9.50
- RealPlayer 10.0.9.809 (gold)

Reproducible: Always

Steps to Reproduce:
elfring@Sonne:~> firefox http://real.amazon-de.eu2.speedera.net/ramgen/real.amazon-de.eu2/phononet/B/0/0/1/4/G/A/K/F/4/01.01.rm
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0xb06aa0)" of type `GString'
/usr/bin/firefox: line 123: 16041 Speicherzugriffsfehler  $MOZ_PROGRAM "$@"
Actual Results:  
Music example from Amazon is not played because of a memory access error.

Expected Results:  
I would like to hear a few seconds of music without application aborts.
(Reporter)

Comment 1

10 years ago
Another play try from the command line:

elfring@Sonne:~> firefox -safe-mode http://real.amazon-de.eu2.speedera.net/ramgen/real.amazon-de.eu2/phononet/B/0/0/1/4/G/A/K/F/4/01.01.rm
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0x2a8ce80)" of type `GString'
/usr/bin/firefox: line 123: 17710 Speicherzugriffsfehler  $MOZ_PROGRAM "$@"

Comment 2

9 years ago
doesn't sound like FF problem. Do you still see this?
Whiteboard: closeme 2009-06-26
(Reporter)

Comment 3

9 years ago
I can not reproduce this issue with Firefox 3.0.11-5.2 together with RealPlayer 11.0.1.1056 plugins.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.