Excessive CPU and memory usage on at least 6 different systems

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: caffeine.lord, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071719 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071719 Firefox/3.0.1

NOTE: I have experienced the following on 6 uniquely different systems, ranging from 1.5ghz 256mb ram to 3.2ghz 4gig ram

Other applications open: none other than bare system software (e.g. window manager)
System state: ranging from fresh install to couple months old
system resource usage before: load average: 0.01, cpu usage: 0.5%

after opening firefox and loading a couple of tabs (max of 7):
cpu usage: at LEAST 60%, load average: 4.xx

resourse usage of firefox being left idle for an hour: no change

after firefox either crashes and closes itself, or stops responding and is force killed, or in the rare instance it accepts a standard quit message:
same resource usage as before using firefox. In Windows it can often be impossible to kill firefox in this state and requires a hard reset (as firefox is using almost 4 gig of memory on that system!!!!!!)

Example pages: Google, Gmail, Hotmail, MySpace, Youtube, Facebook, and almost any other site with moderate usage of images and/or css and/or javascript

Most noticable performance bottleneck: loading pages, closing pages(freeing up memory - can take some minutes to close after receiving a quit message), or switching between tabs. Can take substantial time to switch/render the tab (tespite the tab control responding instantly). closing a tab can also take substantial time despite the cross responding to the click.
Sometimes using the scrollwheel on an un-rendered tab causes the rendering engine to kick in instantly

Number of times Firefox ate up massive system resources and stopped responding/disappeared trying to get to this site alone: 3

Operating systems this has happened on are Windows (XP/Vista), Ubuntu Linux (Hardy), Debian Linux (Etch)

Reproducible: Always

Steps to Reproduce:
1.Use Firefox and watch system resources


Expected Results:  
Firefox consumes an acceptable amount of resources as Firefox 2.0.0.14 did
(Reporter)

Comment 1

10 years ago
Example system load from Top:

top - 22:50:28 up 2 days,  3:18,  2 users,  load average: 1.71, 1.45, 1.10
Tasks: 144 total,   3 running, 141 sleeping,   0 stopped,   0 zombie
Cpu0  : 60.5%us,  1.3%sy,  0.0%ni, 37.3%id,  0.0%wa,  0.0%hi,  1.0%si,  0.0%st
Cpu1  : 63.2%us,  1.6%sy,  0.0%ni, 35.2%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   1815344k total,  1404032k used,   411312k free,    20088k buffers
Swap:        0k total,        0k used,        0k free,   742724k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                         
21780 ryan      20   0  541m 248m  27m R  125 14.0  43:22.42 firefox                                                                                         
 6038 root      20   0  107m  58m  10m S    3  3.3 236:17.58 Xorg                                                                                            
 6551 ryan      20   0 81184  40m 7444 S    1  2.3 162:41.05 compiz.real
22924 ryan      20   0  2308 1144  856 R    1  0.1   0:00.06 top
wfm with all the Gecko builds from the 3 year old FF2.0.X to now, including FF3.0 and 3.0.1 on win32.
Near impossible to fix without some steps to reproduce...

Do you get the same problem in the Firefox safemode ?
http://kb.mozillazine.org/Safe_mode

Comment 3

9 years ago
=> incomplete due to no response to comment 2.

if you update bug, please do so based on starting in safe mode
 https://support.mozilla.com/en-US/kb/Safe+Mode
with beta
 http://www.mozilla.com/en-US/firefox/all-beta.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.