Background images in background-image rule don't animate when -moz-border-image is specified too

REOPENED
Unassigned

Status

()

Core
Layout
REOPENED
10 years ago
8 months ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---
Bug Flags:
blocking1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 330510 [details]
animated gif needed for testcase

See upcoming testcase, animated images don't animate anymore with background-image set and -moz-border-image set. They also don't animate in the border-image.
(Reporter)

Comment 1

10 years ago
Created attachment 330511 [details]
testcase

Perhaps this is basically the same as bug 445810? Clicking in the offending area makes the fish move one time.
I don't see this in my tree, which has the bug 445810 patch in it.
(Reporter)

Comment 3

10 years ago
Ok, marking it a duplicate of bug 445810 then.
No longer blocks: 378217
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 445810
(Reporter)

Comment 4

9 years ago
This works in current trunk build, now that bug 445810 was fixed, but on reload, I see often that the images stop animating after a short while (<1s).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Flags: blocking1.9.1?
Don't clearly see why this should block 3.5, please renominate with rationale if I'm missing something.
Flags: blocking1.9.1? → blocking1.9.1-
Hmm.  I guess bug 445810 did land for 1.9.1.  This is probably ok not blocking then.
(Reporter)

Updated

8 months ago
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago8 months ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.