Last Comment Bug 446342 - Want to configure Firefox updates to be silent (Usability)
: Want to configure Firefox updates to be silent (Usability)
Status: RESOLVED DUPLICATE of bug 890770
:
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: unspecified
: All All
: -- enhancement with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Robert Strong [:rstrong] (use needinfo to contact me)
Mentors:
: 508005 (view as bug list)
Depends on: 489138
Blocks: 561146
  Show dependency treegraph
 
Reported: 2008-07-20 17:30 PDT by Jon
Modified: 2013-07-29 17:45 PDT (History)
20 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jon 2008-07-20 17:30:00 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

My mother is not very computer literate.  She's learnt to use her computer by rote learning - e.g. she knows she can turn the computer on, double click the "Internet" icon, and Google comes up.  (I have set up her computer for her so the "Internet" icon on the desktop launches Firefox, and Google is her homepage).

She doesn't understand about Firefox updates.  When a Firefox update comes out she gets confused - both by the update UI, and also by the "you've updated" page.  Firefox updates happen rarely, so it's harder for her to learn how to handle them.

I want to configure Firefox for her so that she never sees any update dialogs (except perhaps the "installing updates please wait" dialog, which goes away if she just waits).  The update should be downloaded automatically and installed the next time Firefox starts.  The "you've updated" web page should not be shown.

A preference (visible or hidden) would be an acceptable way to fix this.  (I could set the preference for her in advance).

Reproducible: Sometimes

Steps to Reproduce:
1. Release Firefox update
2. Wait for my Mum to get the update

Actual Results:  
The update dialog appears and confuses Mum.
I get a telephone call asking for help.

Expected Results:  
Mum does not notice anything.  She automagically gets the latest security patches when she next restarts her browser.
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2008-07-20 17:36:37 PDT
Do you have "Automatically download and install the update" selected in options (it is the default)?

You can lock the existing prefs so "Automatically download and install the update" can't be changed so it will always download and install on next run of the application when an update is available.
http://kb.mozillazine.org/Locking_preferences

Does this cover your request except for the update first run page after upgrade?
Comment 2 Jon 2008-07-23 16:18:17 PDT
Hi,

Thanks for looking at this.

> Do you have "Automatically download and install the update" selected
> in options

Yes.  (I also have "warn me if this will disable any of my addons" ticked).

> Does this cover your request except for the update first run page
> after upgrade?

No.  I still get the UI described on
http://support.mozilla.com/en-US/kb/Upgrading+Firefox :
> # When an update is available, the Software Update dialog
>   is automatically displayed. [...] To begin updating your
>   software, click OK.
> # When the install process is complete, you must restart
>   Firefox. To close Firefox and re-open it, click Done. 

And I don't want my Mum to have even that minimal user
interaction - I want it to "Just Work", completely silently.

Comment 3 Tyler Downer [:Tyler] 2008-08-16 18:49:07 PDT
This should be an enhancement request, since you want a new feature. I don't know if for security reasons this should be enabled though. 

BTW, you may want to upgrade your Mother's computer to Firefox 3, for general security, usability, and feature upgrade. That won't fix this bug, if if a fix is ever developed for this bug, it will be with FF3.
Comment 4 Matthias Versen [:Matti] 2009-08-03 09:31:26 PDT
*** Bug 508005 has been marked as a duplicate of this bug. ***
Comment 5 Jesse Ruderman 2009-08-25 10:10:45 PDT
Bug 489138 could fix this for minor updates.  Fixing it for major updates is more controversial, but I'm in favor.
Comment 6 Mark Banner (:standard8, limited time in Dec) 2010-02-10 23:38:04 PST
Setting the pref "browser.startup.homepage_override.mstone" to "ignore" should do at least disable the what's new/you've updated page.
Comment 7 Steffen Wilberg 2013-07-29 17:45:50 PDT
Forward-duping to bug 890770, which has a good and up-to-date description.

*** This bug has been marked as a duplicate of bug 890770 ***

Note You need to log in before you can comment on or make changes to this bug.