Closed Bug 446367 Opened 12 years ago Closed 12 years ago

User-agent for messages doesn't follow branding type (Official/Unofficial)

Categories

(Thunderbird :: Build Config, defect, P3, minor)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: standard8)

References

Details

When we build with unofficial branding, our full user-agent is similar to:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2pre) Gecko/2008072021 Shredder/3.0a2pre

Change Shredder to Thunderbird for official branding.

When we send emails, we are currently including the following in the header whether or not we are officially branded:

User-Agent: Thunderbird/3.0a2pre (Macintosh; 2008072021)

I think we should change this to Shredder to fully reflect the full user-agent.

We currently do:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/compose/src/nsMsgCompUtils.cpp&rev=1.199&mark=501,510#490

and get the Name from the app info, and hard-code the MOZ_APP_VERSION.

We can either:

1) Hard-code the name from MOZ_APP_DISPLAYNAME (and keep the MOZ_APP_VERSION hard coded)
2) Use the value of the pref general.useragent.extra.thunderbird which is correctly formatted at compile time, and is used for the full user-agent string.

I'm tending towards 2 as its re-using what we have already.

Thoughts?
Priority: -- → P3
Or you could just use the pHTTPHandler->GetUserAgent(userAgentString) call for Shredder builds...
1) seems like like a very small change, I think I'd go for that. More flexibility, and i don't really see the need to involve general.useragent.extra.thunderbird.
(In reply to comment #2)
> 1) seems like like a very small change, I think I'd go for that. More
> flexibility, and i don't really see the need to involve
> general.useragent.extra.thunderbird.

I've just remembered the downside to 1. If we use MOZ_APP_DISPLAYNAME, then we'll have to format it (or put comments in somewhere) so that we don't get spaces in it (which the user-agent spec doesn't allow).

general.useragent.extra.thunderbird is already formatted for this.

Karsten's option of using the full user-agent is also an option as then we'd be able to get things like the Lightning part of the UA in as well.
The current MOZ_APP_DISPLAYNAME is just "Thunderbird" (or Shredder), no? Or are you thinking about people rebranding to something with a space?

I wouldn't like the full http user-agent. It's sooo ugly.
(In reply to comment #4)
> The current MOZ_APP_DISPLAYNAME is just "Thunderbird" (or Shredder), no? Or are
> you thinking about people rebranding to something with a space?

Yes I'm thinking that if someone rebrands (or say we did in the future) then we may want to have this pre-formatting.
Duplicate of this bug: 448475
(In reply to comment #4)
> I wouldn't like the full http user-agent. It's sooo ugly.
User-Agent is not displayed by default on the header-pane and if you don't like it just don't look at it ;)
Full UA would be way more useful and maybe finally it would not be needed to install Mnenhy extension for this particular feature.
http://mnenhy.mozdev.org/doc-intro.html#tips :
> The User-Agent string currently provided by Thunderbird violates Usefor rules
> and hampers support enormously, especially of localized versions, because it
> does not provide enough information (but Mozilla still does). Mnenhy restores
> the format used by Mozilla.
(In reply to comment #7)
> (In reply to comment #4)
> > I wouldn't like the full http user-agent. It's sooo ugly.
> User-Agent is not displayed by default on the header-pane and if you don't like
> it just don't look at it ;)

But I like looking at it normally;) I have mailnews.headers.showUserAgent set to true, it's interesting to see what people use. Mail clients tend to have fairly pretty UA. (I wish browsers did too, only Opera has taken that step so far.)
Marking as fixed by Bug 230182 ?
(In reply to comment #9)
> Marking as fixed by Bug 230182 ?

Yes, that bug has fixed this bug. Thanks for reminding me.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.