Right click in the current page results previous visited page to appear

RESOLVED DUPLICATE of bug 403540

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 403540
10 years ago
10 years ago

People

(Reporter: Elena Bashmakova, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071719 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071719 Firefox/3.0.1

Very often when I right click on the page (in order, for example, to open some link in new tab, copy smth, etc), then immediately I get previous visited page on the current tab. Then I have to press "Back"/ "Forward" in order to get the same page I had.

Reproducible: Sometimes

Steps to Reproduce:
1.Open several web pages one after another using the same tab, using navigation, clicking links
2.Right click on the last wep page you ended up within your web-surfing chain

Actual Results:  
I see one of the previous pages (The whole picture/whole webpage appearance changes to one of the previously visited)

Expected Results:  
Context Menu of Mozilla (Copy Link, Open in New Tab/ Window, etc)

Happens not all the time, I guess just typing adresses one after one is not enough (like google.com + press Enter, yahoo.com + press Enter). More complicated Navigation makes wonderful Mozilla to crush =)

Comment 1

10 years ago
Does safe mode fix the problem?
http://support.mozilla.com/kb/Safe+Mode

Works for Me.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008072002 Minefield/3.1a1pre ID:2008072002
(Reporter)

Comment 2

10 years ago
Thank you, will try to reproduce the problem in the safe mode (normally I experience this problem almost every day).
(Reporter)

Comment 3

10 years ago
Found out scenario to reproduce it:

Open any website. Exmaple: google.com.

Write something in the search text area. Example "lalala"

Click "Search".

Click "Back" in the browser menu in order to go back to the initial search page (first visited page, the one without search results)

Right-click on it, trying to reach context menu. Immediately  you get the last visited page instead of one you wanted context menu for. So, the page with search results is suddenly displayed even though you didn't want it.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403540
You need to log in before you can comment on or make changes to this bug.