Edit Options... Button does not respond in popup notification: Firefox prevented this site...

VERIFIED INVALID

Status

()

Toolkit
Safe Browsing
VERIFIED INVALID
10 years ago
4 years ago

People

(Reporter: Jason Kleidouhakis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

This app is currently featured on Download.com's main page but cannot be downloaded using firefox. They neglected to make an alternative download link available. Other applications download fine from the same site.

When I click "Download Now" the following notification appears:
"Firefox prevented this site... (www.download.com) from asking you to install software on your computer."
The notification contains the "Edit Options..." button which clicks but nothing happens. The little red eXit button removes the notification.

Under Tools-Options-Content the "Block pop-up windows" checkbox is clear.

This is the page with the "Download Now" link:
http://www.download.com/PDF-Download/3000-11745_4-10455334.html?tag=fd_dek

This URL is where the problem is:
http://dw.com.com/redir?edId=3&siteId=4&oId=3000-11745_4-10455334&ontId=11745_4&spi=1d73bda4ffa21e36ef86bc2ad7dc7ee8&lop=link&tag=tdw_dltext&ltype=dl_dlnow&pid=10866550&mfgId=6276795&merId=6276795&destUrl=http%3A%2F%2Fwww.download.com%2F3001-11745_4-10866550.html%3Fspi%3D1d73bda4ffa21e36ef86bc2ad7dc7ee8

I selected the "block pop-up windows" checkbox and included download.com in the exceptions list, no effect. I did not think to restart firefox, i'll do that in a sec.

Am I missing something?

Note: I am at work behind a firewall but would none-the-less expect this functionality to work.

Update: I was able to download the file using IE-Tab. It is the only Add-on I use. To my surprise the file is a .xpi file: (pdfdownload_2.0.0.0.xpi)
Maybe firefox is treating it different?

The xpi extension does not appear under Tools-Options-Content-File Types(Manage)

Reproducible: Always

Steps to Reproduce:
1. Follow the link above.
2. Click on "Edit Options..." button.
Actual Results:  
No download window appears when the page loads.
Notification is displayed.
Nothing happens when the button is clicked.

Expected Results:  
"Save As" prompt to appear.
Given the notification with a button, it should do something. (open settings page)

MS Windows XP 2002
Service Pack 2
Intel Pentium
This is a Novell system
I do not have administrative privileges on this machine. I do not currently have access to another system to help diagnose the issue.
(Reporter)

Comment 1

10 years ago
Ok after searching bugs for ".xpi" I'm convinced it's related to the file extension. Looks like someone else is using it for something else and firefox needs to prompt to download the file instead of trying to run it.

Although I can't do anything with it after it's downloaded either...

G2G, I'll follow up later.

PS. See Also: 446394 (Don't know if this is a duplicate or not.)
It's an external xpi file that does not reside on addons, so it's not supposed to bring up the pop-down bar to save the xpi. It gives the option to save the file instead.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090602 Shiretoko/3.5pre ID:20090602044233
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.