Session restore only restores first two windows

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Administration
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: Geoff Halprin, Unassigned)

Tracking

Details

Attachments

(8 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Several times now, [re]starting Firefox correctly reloads all tabs in the first two windows, but the third window does not appear. In the "Window" menu, the third window appears as "Mozilla Firefox" but is not selectable. Restarting Firefox again restores the same two windows, but this time no third window appears even in the window list.

There are about 8 tabs in the first window, and 3 in the second.


Reproducible: Always

Steps to Reproduce:
1. Open several windows, each with multiple tabs.
2. Restart Firefox.
3. Only first two windows are restored properly.
Actual Results:  
It's a little difficult to test this as I write this bug report. I'll try a few things and add them to the ticket.
(Reporter)

Comment 1

10 years ago
Created attachment 330576 [details]
Screenshot of incorrect behaviour

When I opened a new window (after failed session restore, with empty window still in window list), the new window appeared as attached. (Menus are offset beyond left edge of window.)
(Reporter)

Comment 2

10 years ago
Created attachment 330577 [details]
Re-attached screen shot as GIF
(Reporter)

Comment 3

10 years ago
Created attachment 330688 [details]
Screenshot showing phantom window in menu after restart

This screen shot was taken after a Firefox restart. The third window (3 tabs) was lost. The Window menu shown lists a third window as "Mozilla Firefox", but this window cannot be selected. Those tabs in the third window have been lost.

Comment 4

10 years ago
Geoff, if you are able to reproduce this issue, the following would help debugging it: Copy the file sessionstore.js from your profile right before and right after restarting Firefox (resp. right before shutting it down and when it's completely quit) and attach both copies to this bug after you've made sure that Firefox indeed doesn't correctly restore the session in the way you describe.

Privacy note: You might want to inspect both files with a text editor first in order to make sure they don't contain privacy sensitive data.
Version: unspecified → 3.0 Branch
(Reporter)

Comment 5

10 years ago
Created attachment 331063 [details]
sessionstore from directly before quit (1st example)

I have removed various private data, and hand formatted the file so I could read it enough to know what I was removing. If I've accidentally removed something you need, please let me know. I've kept the original files.
(Reporter)

Comment 6

10 years ago
Created attachment 331064 [details]
sessionstore from directly after restart (1st example)
(Reporter)

Comment 7

10 years ago
Created attachment 331065 [details]
sessionstore from directly before quit (2nd example)
(Reporter)

Comment 8

10 years ago
Created attachment 331067 [details]
sessionstore from directly after restart (2nd example)

In both examples, I can confirm the third window was corrupted and lost in the same fashion. It appears to happen for any third window. For these examples, I reduced the tab counts right down -- 2 in the first window, 3 in the second, and 2 in the third.

Also, it appears to be consistent that the first "New Window" after restarting with the bug induced third (ghost) window, the toolbars appear offset beyond the left margin as previously attached.

Comment 9

10 years ago
Yeah, the third window just disappears into thin air. A couple of further questions:
* How do you actually restart Firefox?

* Does the same happen when doing quitting Firefox through Cmd+Q and restarting then? And does the same happen when repeating the Steps to Reproduce in Safe Mode?

* If so, does sessionstore.js still contain the data for the third window when Firefox is shut down? (make sure the file reads session:{state:"stopped"}} at the end)
Keywords: qawanted
(Reporter)

Comment 10

10 years ago
Created attachment 331068 [details]
sessionstore from directly after quit [before restart] (1st example)
(Reporter)

Comment 11

10 years ago
(In reply to comment #9)
> Yeah, the third window just disappears into thin air. A couple of further
> questions:
> * How do you actually restart Firefox?

Note that while the third window disappears, a ghost of it still appears in the window list (window menu).

In the above examples, I quit (Cmd-Q) and started again. I have had the same behaviour when using restart (after upgrading add-on, for example).

> * Does the same happen when doing quitting Firefox through Cmd+Q and
> restarting then?

Yep. See above.

> And does the same happen when repeating the Steps to Reproduce in Safe Mode?

I have not played with Safe Mode. Which bits do you want me to disable via safe mode?

> * If so, does sessionstore.js still contain the data for the third window when
> Firefox is shut down? (make sure the file reads session:{state:"stopped"}} at
> the end)

See recent attachment. The third window is still present after quit.

Comment 12

10 years ago
(In reply to comment #11)
> Which bits do you want me to disable via safe mode?

Your add-ons, and that'll happen automatically (you won't have to make any of the changes permanent).

> See recent attachment. The third window is still present after quit.

Thanks. If this isn't due to an extension, this looks like a new Mac specific bug you've discovered there.
(Reporter)

Comment 13

10 years ago
(In reply to comment #12)
[...]
> Thanks. If this isn't due to an extension, this looks like a new Mac specific
> bug you've discovered there.

Well, I've spent the last hour disabling/enabling extensions and the culprit is ... [drumroll] ... NoScript 1.7.7 [1].

I'm not sure when the bug crept in, but I guess I'll follow up with them.

Thanks for the help,

-g.

[1] I progressively disabled small groups of extensions and when things started working I enabled the last batch one at a time; then disabled/re-enabled the culprit to confirm, then disabled it and re-enabled all the others to confirm.

Comment 14

10 years ago
(In reply to comment #13)
Resolving this bug as WORKSFORME, then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 15

10 years ago
WFM with NoScript 1.7.7.6 from http://noscript.net/getit#devel and
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Could you check the version above, and if the problem persist retry Standard Diagnostic keeping NoScript in your list to rule out conflicts with other extensions of yours?
(Reporter)

Comment 16

10 years ago
Giorgio: (Sorry for the delay in getting back to you.)

Lots more testing[1], and evidence strongly suggests this is an interaction between NoScript and SwitchProxy which is causing the observed behaviour.

If either of these is disabled, then everything is ok. With both enabled, the
problem is observed. With no other extensions except these two enabled, I was
able to observe the described behaviour. Disabling either returns behaviour to
normal. Swapping the enabled one continues to work. Adding all add-ons back, except SwitchProxy works. All add-ons except NoScript works.

(Testing was with NoScript 1.7.7 and confirmed with 1.7.7.6)

[1] Testing was to remove all add-ons other than NoScript, then add back one or two at a time until things broke. Once things broke, I confirmed the conflict by removing the conflicting add-on and NoScript in turn to confirm the conflict. Then I removed everything except the two in question to confirm the conflict. Then I added everything back including NoScript, but excluding SwitchProxy.

The list of add-ons involved in testing is below:

1Password, Aadvark, AdBlockPlus, AdBlockFilterSetG, Better GCal, Better Gmail2, Dictionary Switcher, Australian Dictionary, Errorzilla Mod, Firebug, Flagfox, Flashblock, Foxmarks, Greasemonkey, NoSquint, Print Preview, Stylish, User Agent Switcher, View Cookies, Yslow.
Component: Session Restore → Add-ons
Product: Firefox → addons.mozilla.org
Version: 3.0 Branch → unspecified
Component: Add-ons → Administration
QA Contact: session.restore → administration
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.