Problem ftp-ing into my home directory

VERIFIED DUPLICATE of bug 31586

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 31586
18 years ago
18 years ago

People

(Reporter: Gady Kozma, Assigned: Robert John Churchill)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000613
BuildID:    2000061311

When ftp-ing, mozilla automatically cd's to /. This is really inconvinient for
me because my home is in a very deep, constantly changing, unguessable position
in the directory tree. With netscape, I could omit the trailing / in the url
like that:
ftp://gady@gemini.math.tau.ac.il
And it would take me to my $HOME and replace the URL with the real one
ftp://gady@gemini.math.tau.ac.il/a/blah blah blah
This doesn't seem to work for Mozilla and I couldn't find any other solution to
my problem.

Reproducible: Always
Steps to Reproduce:
1.Click the url line.
2.Write ftp://your_name@your_computer
3.Press enter

Actual Results:  I got the listing of the files at /.

Expected Results:  I should have got $HOME.

Comment 1

18 years ago
Saw this with win32 build 2000070508.  As reported,
ftp://username:password@domain.com will always return the root directory
(regardless of a trailing slash in the URL), not the user's home directory.
This seems to stem from Mozilla's conversation with the FTP server not including
"PWD", so Mozilla never discovers what the user's home directory is.

NC 4.72's conversation with an FTP server (ftp://{username}:{password}@{hostname}):

<--- 220 {hostname} FTP server (Version 6.00LS) ready.
command: USER {username}
<--- 331 Password required for {username}.
command: PASS  ???
<--- 230 User {username} logged in.
FTP LOGIN FROM {hostname} as {username}
command: REST 0
<--- 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
command: SYST
<--- 215 UNIX Type: L8 Version: BSD-199506
command: PWD
^^^^^^^^^^^^
<--- 257 "/usr2/home/{username}" is current directory.
command: PASV
<--- 227 Entering Passive Mode (151,204,38,2,192,199)
command: TYPE I
<--- 200 Type set to I.
command: SIZE /usr2/home/{username}
<--- 550 /usr2/home/{username}: not a plain file.
command: MDTM /usr2/home/{username}
<--- 550 /usr2/home/{username}: not a plain file.
command: RETR /usr2/home/{username}
<--- 550 /usr2/home/{username}: not a plain file.
get /usr2/home/{username}
command: CWD /usr2/home/{username}
<--- 250 CWD command successful.
command: LIST
<--- 150 Opening BINARY mode data connection for '/bin/ls'.
<--- 226 Transfer complete.
<--- 221 You could at least say goodbye.

Mozilla's conversation with an FTP server (ftp://{username}:{password}@{hostname}):

<--- 220 {hostname} FTP server (Version 6.00LS) ready.
command: USER {username}
<--- 331 Password required for {username}.
command: PASS  ???
<--- 230 User {username} logged in.
FTP LOGIN FROM {hostname} as {username}
command: SYST
<--- 215 UNIX Type: L8 Version: BSD-199506
command: PASV
<--- 227 Entering Passive Mode (151,204,38,2,192,208)
command: TYPE I
<--- 200 Type set to I.
command: SIZE /
<--- 550 /: not a plain file.
command: MDTM /
<--- 550 /: not a plain file.
command: CWD /
<--- 250 CWD command successful.
command: LIST
<--- 150 Opening BINARY mode data connection for '/bin/ls'.
<--- 226 Transfer complete.
command: PASV
<--- 227 Entering Passive Mode (151,204,38,2,192,209)
command: TYPE I
<--- 200 Type set to I.
command: SIZE /
<--- 550 /: not a plain file.
command: MDTM /
<--- 550 /: not a plain file.
command: CWD /
<--- 250 CWD command successful.
command: LIST
<--- 150 Opening BINARY mode data connection for '/bin/ls'.
<--- 226 Transfer complete.
lost connection

...as seen, Mozilla doesn't issue "PWD", and always assumes the root directory.
 Confirmed, and changed component to Networking.
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true

Comment 2

18 years ago
setting default owners
Assignee: asa → gagan
QA Contact: doronr → tever

Comment 3

18 years ago
Dup of 31586 ?

Comment 4

18 years ago
robert-- welcome to necko!
Assignee: gagan → rjc
(Assignee)

Comment 5

18 years ago


*** This bug has been marked as a duplicate of 31586 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.