excessive amount of dialogs

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: WSourdeau, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr-FR; rv:1.9.0.1) Gecko/2008071420 Iceweasel/3.0.1 (Debian-3.0.1-1)
Build Identifier: 0.8

When the same error occurs repeatedly, error dialogs popup as many times as the error occurs. This poses a serious problem when the user keeps Lightning running in the background. Instead of that, a model should probably be designed where any Lightning action of the same "type" would stop as long as the first dialog related to this "action type" has not been ackowledged. Another possibiliy would be to stack the errors in the same dialog. The aim behind those two suggestions being to avoid repeated popups, which:
- disturb the user's current activity (one warning/problem is enough)
- can fill the GUI's list of open windows pretty quickly

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I am wondering why that happens, because IIRC there's already code in 0.8 that hinders popping up duplicate errors (in calCalendarManager.js). However, the error notifications have been revised by Berend recently (though there are still some missing pieces).
Wolfgang, does this still happen with Lightning 0.9?
Component: General → Lightning Only
QA Contact: general → lightning
This works for me, closing for now. please reopen if the problem persists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.