Firefox 3 ignores mailto user preference

RESOLVED DUPLICATE of bug 428658

Status

()

RESOLVED DUPLICATE of bug 428658
11 years ago
10 years ago

People

(Reporter: gustavo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

On firefox 2 the application handler for mail: URIs could be set using a line like this one:

user_pref("network.protocol-handler.app.mailto", "/usr/bin/kmailservice");

on the globl prefs.js

On Firefox 3, this preference is ignored, although it originates an entry on the list of mail handlers (cf screenshot).

The solution is not using this pref and generating the corresponding RDF blocks for mimeTypes.rdf, which is a very cumbersome solution.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Created attachment 330656 [details]
mail handling entry

this screenshot shows an entry which appears due to the user pref, but which has no action whatsoever

Comment 2

10 years ago
This bug hit me and I found a workaround.
Exit firefox, remove/delete mimeTypes.rdf, start firefox,
click on a mailto link. The dialect for mailagent pops up. Set to the location of kmailservice. Kmail should pop up right after setting it.

I notice that the network.protocol-handler.app.mailto disappears. I think the developers move the setting without telling anyone about it.

Note that deleting the network.protocol-handler.app.mailto might work also.
(Reporter)

Comment 3

10 years ago
Hello Techwolf,

Your suggestion works but is not packageable! We need something that works by default without any user action.

Actually we found a way by looking at mimeTypes.rdf after a manual change and porting the corresponding changes to the default mimeTypes.rdf on $FIREFOXDIR/defaults/profile. 

But it is a messy procedure, much worst than the previous user_pref.

By the way, the same problem applies to mms:// and other handlers that one may wish to define as defaults.
Part of File Handling... moving
Component: OS Integration → File Handling
QA Contact: os.integration → file.handling

Comment 5

10 years ago
Thats why I said workaround, not a solution. Solution is to look at user preferences and migrate the settings from there to the rdf file upon upgrade.

Comment 6

10 years ago
Appears to be a duplicate of 428658.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428658
You need to log in before you can comment on or make changes to this bug.