JavaScript-disabled slider's Previous and Next buttons don't work

VERIFIED FIXED in 5.0.6

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: stephend, Unassigned)

Tracking

unspecified
5.0.6

Details

(Reporter)

Description

10 years ago
With JavaScript disabled, the slider's Previous and Next buttons don't work.  Wasn't caught with bug 432669; I think the original iteration I tested worked with JS disabled, but not the final.
Huh, I've never seen the prev/next buttons work without JS myself - it's kind of a JS-dependent widget from the ground up.  I can take a look rewriting it to work in absence of JS though, if you saw it working that way before.
(Reporter)

Comment 2

10 years ago
No, I'm confused (happens all too often, I'm 'fraid) -- bug 432669 comment 30 clearly states that it didn't work with JS; do we want this bug to cover the remaining suggestions rdoherty alluded to in bug 432669 comment 31, or is that too much for one bug?

Comment 3

10 years ago
That depends on which suggestions rdoherty made :) In general, I think it should either work without JS as well, or it should gracefully fall back to something similar (like a div with a left/right scrollbar, maybe?).
The front-page slider is now non-JS accessible since AMO 5.0.6.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 5.0.6
(Reporter)

Comment 5

9 years ago
Verified FIXED.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.