Closed Bug 446571 Opened 12 years ago Closed 7 years ago

Domain portion of addresses should be treated as case-insensitive

Categories

(MailNews Core :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 30.0

People

(Reporter: pkgale, Unassigned)

References

Details

(Whiteboard: [fixed by bug 129393])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: version 2.0.0.14 (20080421)

An e-mail address is local@domain. The local part may be case-sensitive, but the domain part must be case-insensitive. Therefore the address book should treat user@Example-DOmain.COM and user@example-domain.com as the same address. Right now, T-Bird creates different address cards for each case-sensitive variation.

Reproducible: Always

Steps to Reproduce:
1. Go to Tools -> Options -> Composition -> Addressing and select "Automatically add outgoing e-mail addresses to my: Personal Address Book".
2. Send an e-mail to yourself using different case-sensitive variations on the domain, like user@domain, user@DOMAIN, and user@Domain.
3. Look at your address book.
Actual Results:  
You should have multiple user@domain entries. 

Expected Results:  
T-Bird should parse the domain portion with case-insensitive rules, then try to match against an existing entry. If a match is found, do not add a new entry. If a match is not found, then add a new entry using the user's exact *case-sensitive* user@DoMaIn format.
Is this bug report a duplicate of bug 446574 or just a reduced version, as it
does not ask for an option but should unconditionally match existing entries regardless of the case? Even if the latter applies, these bugs could probably
be combined to a single one in which the optional-or-not question is decided.
These are not duplicates, as the RFCs governing each part are different. The domain MUST be case-insensitive, so T-Bird should always treat it as such. The local part (user) MAY be case-sensitive, but it is discouraged. I'm not aware of any mail agents that are currently configured for case-sensitivity, but since some companies (Microsoft in particular) have a history of ignoring standards by way of embracing and extending, T-Bird should allow for this option in the future.

My guess is that the local part will be case-insensitive for the majority of mail agents for a long time. If the whole user@domain string was treated as case-insensitive for matching purposes, then that would probably be fine.
If Bug 129393 were fixed, I would not have filed this one or #446574 (to handle the local part). As of today, I'd like for this both this one and bug 446574 to be fixed because they give specific instructions to the coders as to how the complete issue should be fixed. Bug 129393 is not as specific. Agreed?
somewhat dupish, but I'm bug 129393 probably hits both this and bug 446574 and even more. so going with dependency
Blocks: 129393
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: address-book → addressbook
Bug 58769, Bug 129393 and Bug 446574 also have comments about collecting addresses and case sensitivity.
To the best of my knowledge the case sensitivity bug still exists in the main code.  To get it fixed please go to bug 129393 and click the vote button to raise its level of importance.
Fixed by bug 129393.
Status: NEW → RESOLVED
Closed: 7 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: [fixed by bug 129393]
Target Milestone: --- → Thunderbird 30.0
You need to log in before you can comment on or make changes to this bug.