Open/Save attachment dialog displays name with % for spaces

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: laurel, Assigned: Diane Sun)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Using jul6 commercial build NT 4.0 and Linux rh6.0
Haven't successfully gotten to mac yet, assume same result

The Open/Save attachment dialog displays attachment name with percent sign (%)
instead of spaces.

1.  Go to mail window, login to mail account. Forward yourself a message with
spaces in the message subject, use setting for forward as attachment.
2.  Get the message, select it.
3.  Click on the attachment icon in the message header envelope area, note the
attachment name (title of original message) is displayed correctly with spaces.
4.  Click on the attachment name to select it and launch the Open/Save
attachment dialog.  Note the attachment name in the dialog has the spaces
represented with %.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → pmock

Comment 1

18 years ago
reassigning to jefft.
Assignee: putterman → jefft

Comment 2

18 years ago
adding rhp. Rich will be able to help me if this bug becomes more urgent.
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 3

18 years ago
Nominating for nsbeta3 and polish. This would look foolish if we ship with this.
Keywords: nsbeta3, polish

Updated

18 years ago
Keywords: mail2

Updated

18 years ago
Keywords: mail2 → mail6

Comment 4

18 years ago
mail triage marking [nsbeta3-]
Whiteboard: [nsbeta3-]

Comment 5

18 years ago
per email, reassign to diane sun to help.  Thanks!
Assignee: jefft → dianesun
Status: ASSIGNED → NEW

Comment 6

18 years ago
I am not able to reproduce the problem using the following builds:
 win32 commercial seamonkey build 2000-082504-m18
 linux commercial seamonkey build 2000-082508-m18
 macos commercial seamonkey build 2000-082506-m18

It looks like it worksforme.
Laurel, are you still seeing the problem? 
(Assignee)

Comment 7

18 years ago
Both pmock and myself could not reproduce it with latest build. Close it as 
"WORKSFORME".
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
Verified as worksforme.
Laurel, if you still this bug, please re-open.  Thanx.
Status: RESOLVED → VERIFIED

Comment 9

16 years ago
This consitently happens for me on files sent to me from a Mac using other mail
clients.  Doesn't happen for PC attachments.  The same attachments show up
correctly with old netscape messenger.  It might be that the resource fork file
name (which shows up with a % sign on some other mail clients is being used
instead of the real file name.  

In using "Execmail" both filenames (one with and one without the %) sign shows up.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

16 years ago
QA Contact: pmock → trix
s.kumar@anderson.ucla.edu:
marking worksforme again.
Please file a new bug if you see this with a recent build !
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
unable to duplicate this problem using mozilla & netscape builds 2002022703.
verified wfm
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.