SM, MC: dense array previous "length" value is not reported correctly in watch callback (js1_5/extensions/regress-435345-01.js)

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: bc, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Bug Flags:
wanted1.9.0.x +
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
BUGNUMBER: 435345
STATUS: Watch the length property of arrays
 FAILED! [reported from test()] Watch the length property of arrays: 1 : Expected value 'watcher: propname=length, oldval=0, newval=1; ', Actual value '' 
 FAILED! [reported from test()] Watch the length property of arrays: 2 : Expected value 'watcher: propname=length, oldval=1, newval=2; watcher: propname=length, oldval=2, newval=2; ', Actual value 'watcher: propname=length, oldval=undefined, newval=2; ' 
 FAILED! [reported from test()] Watch the length property of arrays: 3 : Expected value 'watcher: propname=length, oldval=2, newval=1; ', Actual value 'watcher: propname=length, oldval=undefined, newval=1; ' 
 FAILED! [reported from test()] Watch the length property of arrays: 4 : Expected value 'watcher: propname=length, oldval=1, newval=2; ', Actual value 'watcher: propname=length, oldval=undefined, newval=2; ' 
 FAILED! [reported from test()] Watch the length property of arrays: 5 : Expected value 'watcher: propname=length, oldval=2, newval=5; ', Actual value 'watcher: propname=length, oldval=undefined, newval=5; '
Flags: in-testsuite+
Flags: in-litmus-
Flags: blocking1.9.0.2?
Brian, can you look at this? If it's a regression we probably need to block on it and get a fix in asap.
Assignee: general → crowder
Keywords: regression
Flags: wanted1.9.0.x+
Does that mean "don't fix it at all" or "don't need to rush it into 1.9.0.2" ?
Flags: blocking1.9.0.2? → blocking1.9.0.3?

Comment 4

10 years ago
It would be nice to have, but I think it is not wildly important or high-priority.  watch() is, itself, a spidermonkey extension, and watching the "length" property of an array is relatively obscure.  Ideally, we should fix this, but I think it means making shavarrays slower (perhaps measurably so).
Dan: we should take the fix into a patch release. Further bugs may be fixed later. There's no reason to wait for perfection before putting this bug's fix into the patch-stream, though, and this bug is a regression from Firefox 1-2.

/be

Comment 6

10 years ago
fwiw, I landed 435345 today, so all that remains is to fix the reporting of the previous length value.
Flags: blocking1.9.0.4? → blocking1.9.0.4+

Comment 7

10 years ago
The most serious part of this bug landed on the branch in bug 435345 (watch didn't work -at all- for array length).  I'm morphing this bug to reflect the remaining piece, which is of lower severity in my opinion, and which may not be fixable without impacting performance measurably.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Summary: SM, MC: js1_5/extensions/regress-435345-01.js FAIL watching array length → SM, MC: dense array previous "length" value is not reported corrected in watch callback
Duplicate of bug: 435345

Comment 8

10 years ago
I'd like it if this one could drop off the blocker list.
Brian, I'm confused. This bug was a follow up to bug 435345 (you said so in comment 26 of that bug), wherein Brendan specifically says (comment 5 of this bug) we should take the fix here in a patch release.

How is it a duplicate of bug 435345?

Comment 10

10 years ago
Err, sorry.  I marked it as a dupe, wrote a dupe comment, and then rewrote my comment without removing the dupe marker.  The comment #7 here is correct, though.  This is a lower-severity bug (not a blocker).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Sold -- not blocking 1.9.0.x
Status: REOPENED → ASSIGNED
Flags: blocking1.9.0.4+

Updated

10 years ago
Summary: SM, MC: dense array previous "length" value is not reported corrected in watch callback → SM, MC: dense array previous "length" value is not reported correctly in watch callback

Comment 12

10 years ago
Mass unowning JS bugs...  I'm not likely to be able to move these forward.
Assignee: crowder → general
Status: ASSIGNED → NEW
(Reporter)

Comment 13

10 years ago
search goodness: js1_5/extensions/regress-435345-01.js
Flags: wanted1.9.2?
Flags: wanted1.9.1?
Summary: SM, MC: dense array previous "length" value is not reported correctly in watch callback → SM, MC: dense array previous "length" value is not reported correctly in watch callback (js1_5/extensions/regress-435345-01.js)
(Reporter)

Updated

6 years ago
Flags: wanted1.9.2?
Flags: wanted1.9.1?
Given that we want .watch to die and this doesn't seem to cause any real-world issues, I'm WONTFIXing. Shout if you disagree.
Status: NEW → RESOLVED
Last Resolved: 10 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.