Closed Bug 446638 Opened 14 years ago Closed 13 years ago

file in use by firefox after uploading through webform

Categories

(Firefox :: Shell Integration, defect)

3.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 183689

People

(Reporter: sonnenberg, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

After uploading any file on my system to any server through the use of a form on a website, the file is still in use by firefox after the upload has completed, and as such I can not move the files around, nor can I edit them.

I have tried many different filetypes, from all different locations, each and every time the same thing happens.

The following error message shows up every time:

"Cannot copy file.ext. It is being used by another person or program.
Close any programs that might be using the file and try again."

(WinXPSP2/FF3.01))

Reproducible: Always

Steps to Reproduce:
1. Upload a file through a form on a webpage
2. Wait for the upload to complete successfully
3. Try and move the uploaded file on your local system
Actual Results:  
The file cannot be moved, I get the following error message:

Cannot copy file.ext. It is being used by another person or program.
Close any programs that might be using the file and try again.

Expected Results:  
The file should be properly released after the upload has completed so it can be moved around, edited, etc.

Released the file lock.

Using default firefox installation, no themes. Firefox doesn't crash. Restarting firefox solves the problem and releases the file.
Version: unspecified → 3.0 Branch
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 183689
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.