Link in signature does not open in webbrowser when clicked

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Pander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071719 Firefox/3.0.1
Build Identifier: 2.0.0.14 (20080505)

Link in (greyed out but ASCII) signature does not open in webbrowser when clicked. This does happen for links in the main body of a message.

Please fix this or make it configurable in Thunderbird Preferences.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

9 years ago
Is the URL valid? If it's a problem in general, try resetting your default browser to see it that helps.
(Reporter)

Comment 2

9 years ago
URL is/are valid. After resetting the default browser in GNOME it still occures. Also opening some links work and others do not work, regardless of a signatures with URL being present.

My system is configured all to default settings regarding this so it also puzzles me. Do you have any other ways to fix this or can you reproduce this? E.g. the URLs in emails from bugzilla-daemon@mozilla.org don't work for me but the ones from bugzilla-daemon@bugzilla.gnome.org do work.

Could it be in possible junk/scam classification?

Comment 3

9 years ago
Are those http vs https ?
(Reporter)

Comment 4

9 years ago
Yes, thanks, that is the limiting factor. Is this a security setting or a bug? Is it possible to enable clicking https links?

Comment 5

9 years ago
Yes it should normally work. There must be something causing it not to get set as default handler for https. 

I'd just try setting something else as default in between, then firefox again.  If that doesn't help, try getting help in the forums.
<http://forums.mozillazine.org/viewforum.php?f=39>

->INVALID as it's not a bug, but something that doesn't work due to some (OS?) wrong config related to default https handler.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

8 years ago
Ah, I've discovered why Thunderbird would not open https:// links. I
thought this had to do something with settings in GNOME for default
applications etc. However recently, I started looking inside the prefs.js file
of Thunderbird version 2.0.0.23.

There I found:
  prefs.js:user_pref("network.protocol-handler.external.https", false);
and changed it to:
  prefs.js:user_pref("network.protocol-handler.external.https", true);
to get it working. This can also be done via the Config Editor in Preferences.

According to me, this should always be set to true. Otherwise, it should popup a question on the first time one clicks on a https:// link whether users would like to open these or would like to block opening these. Also preferences should offer an easy way of controlling this setting.

I don't know if this was inherited from older settings or it is still the defualt, please verify.
Status: RESOLVED → UNCONFIRMED
OS: Linux → All
Hardware: x86 → All
Resolution: INVALID → ---
Version: unspecified → 2.0

Comment 7

8 years ago
Those prefs are obsolete in tb3. (And the default were always true, you, or some extension must have changed it for you.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

8 years ago
Funny thin in Thunderbird 2 is that when I set
  prefs.js:user_pref("network.protocol-handler.external.https", true);
it opens an XML file in Firefox each time it scans for Addon updates.
You need to log in before you can comment on or make changes to this bug.