Closed Bug 446661 Opened 12 years ago Closed 12 years ago

Skype extension breaks Firefox 3.0 restarting

Categories

(Firefox :: General, defect)

3.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: DrDirector, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Firefox 3.0 (and now 3.0.1) does not start properly each time after the application has been closed.  During the restart, I do not get to my normal home page nor do I have access to my "Bookmarks".  The only way to get Firefox to restart properly is to reboot the computer.  Did not have this problem with Firefox 2.x.  Running Windows XP Home Version 2002 with Service Pack 2 and all subsequent MicroSoft updates installed on Dell Latitude D630 operating with 1.7GHzlock speed and 1GB RAM.  Also use Norton 360 2.0 for firewall and anti-virus.  Any suggestions?

Reproducible: Always

Steps to Reproduce:
1. Start Firefox after booting computer.
2. Do whatever is wanted on Internet.  Can have multiple Firefox windows open or just one single window.
3. Close Firefox (all that are open).
4. Restart Firefox.
5. Encounter problem: no home page; no access to "Bookmarks".
5. Reboot computer to get Firefox to restart properly
Actual Results:  
Firefox does not open properly.

Expected Results:  
Firefox should open properly to my home page and give me access to my Bookmarks
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Version: unspecified → 3.0 Branch
Care to share your solution?

Also, the FIXED status is for when Mozilla fixed something with a change, not when your problem is resolved.
Resolution: FIXED → INVALID
If I had a solution I would not have posted the problem.  In fact, I am looking for a solution.  Don't know how this got marked as resolved!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Ah, you must've accidentally selected FIXED when you set it to 3.0 branch.

In that case, please try rebooting then loading up in Firefox safe mode:
http://support.mozilla.com/en-US/kb/Safe+Mode

If you can correctly start Firefox back up again (in safe mode) after that, then it's caused by an add-on of some sort. Disable them one at a time until you find the cause.
Followed your suggestion.  Firefox regularly restarted OK is SafeMode.  Deactivated the five Add-On Extensions (AutoFill Forms 0.9.5.1; Foxmarks Bookmark Synchronizer 2.1.0.12; Yapta 1.3.0.10; Yahoo Toolbar 1.5.2.20080717; and Skype Extension [version no longer known]).  Reactivated one at a time and problem appeared to be with Skype.  Restarts OK with other 4 add-ons, so running without Skype Extension.

Thank you.
 
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1)
> Gecko/2008070208 Firefox/3.0.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1)
> Gecko/2008070208 Firefox/3.0.1
> 
> Firefox 3.0 (and now 3.0.1) does not start properly each time after the
> application has been closed.  During the restart, I do not get to my normal
> home page nor do I have access to my "Bookmarks".  The only way to get Firefox
> to restart properly is to reboot the computer.  Did not have this problem with
> Firefox 2.x.  Running Windows XP Home Version 2002 with Service Pack 2 and all
> subsequent MicroSoft updates installed on Dell Latitude D630 operating with
> 1.7GHzlock speed and 1GB RAM.  Also use Norton 360 2.0 for firewall and
> anti-virus.  Any suggestions?
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Start Firefox after booting computer.
> 2. Do whatever is wanted on Internet.  Can have multiple Firefox windows open
> or just one single window.
> 3. Close Firefox (all that are open).
> 4. Restart Firefox.
> 5. Encounter problem: no home page; no access to "Bookmarks".
> 5. Reboot computer to get Firefox to restart properly
> Actual Results:  
> Firefox does not open properly.
> 
> Expected Results:  
> Firefox should open properly to my home page and give me access to my Bookmarks
> 

Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Not a bug in Mozilla, so this is INVALID not FIXED.

The Skype extension seems to be a piece of junk.
(it even breaks Google Maps; bug 440194)

Please report this issue to the Skype developers.
Resolution: FIXED → INVALID
Summary: Restarting Firefox 3.0 after closing → Skype extension breaks Firefox 3.0 restarting
You need to log in before you can comment on or make changes to this bug.