Closed Bug 446675 Opened 11 years ago Closed 11 years ago

Remove BeOS port of gfx

Categories

(Core Graveyard :: GFX: BeOS, defect)

x86
BeOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1a2

People

(Reporter: joe, Assigned: joe)

References

Details

Attachments

(1 file)

Now that BeOS uses Cairo, we don't need the BeOS port of gfx, and so we should remove it.
Attachment #330817 - Flags: review?(vladimir)
Keywords: checkin-needed
Sergei and Frederik, please comment here.  To my knowledge, the BeOS port of Cairo has not been thoroughly tested and proven to work with Mozilla.
Wasn't there already bug on same topic?

For some reason I though that BeOS gfx was removed from trunk some months ago, and there was also discussion on that problem.
Isn’t this a dupe of bug 419004 ?
Blocks: 449577
No longer blocks: 449577
Duplicate of this bug: 419004
Moving over the dependency from bug 419004 to this one.
Blocks: 376791
As for comment #1 and #2, the current trunk won't compile nor work with the old gfx code at all (for example the current image decoders just don't handle the old gfx way anymore).
(In reply to comment #1)
> Sergei and Frederik, please comment here.  To my knowledge, the BeOS port of
> Cairo has not been thoroughly tested and proven to work with Mozilla.
> 
Only important thing for us in this situation is ability to get from 1.9 all gfx code versions before that coming removal. Hope, CVS is just for that:)
Assignee: nobody → joe
Pushed as 17094:3cf210488afa.
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1a2
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.