In check-one, new log files are not being scanned for PASS/FAIL

VERIFIED FIXED

Status

Testing
XPCShell Harness
--
major
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: rkent, Assigned: sgautherie)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
In bug 443220, a regression was added that causes the unit test log file to be created in a different directory than is scanned. The effect would be, using check-one for example, that PASS/FAIL of tests would not be seen correctly, as it would scan an old version of the log file. A symptom of this is that the .log file appears in the parent of the correct directory when check-one is used.

In lines like this:

NATIVE_TOPSRCDIR="$native_topsrcdir" TOPSRCDIR="$topsrcdir" $xpcshell -s $headfiles -f $testdir/$target_dir/$target_js $tailfiles  2> $testdir/$target_js.log 1>&2

from http://mxr.mozilla.org/mozilla-central/source/tools/test-harness/xpcshell-simple/test_one.sh#136

"$testdir/$target_js.log" should be "$testdir/$target_dir/$target_js.log" to match the file that is scanned for PASS.
Kent - sounds like you know the problem and the fix.  Would you care to submit a patch?

If I were a reviewer in the module, I'd rubber-stamp that fix.  (I pretty much wrote this file, anyway.)
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Kent - sounds like you know the problem and the fix.  Would you care to submit
> a patch?
> 
Ordinarily, I would be happy to do this. The problem is that mailnews (where I am working) just switched to Hg, and I'm still trying to figure all of this out. It may be a few days before I can figure out how to do patches again.

(Assignee)

Comment 3

10 years ago
From bug 443220 comment 3,
{{
Alex Vincent   2008-07-05 01:37:19 PDT

> For the rest of it, I simply replaced "unit/" with "$target_dir/".
}}

But that one line (only) went wrong :-/
Severity: normal → major
(Assignee)

Comment 4

10 years ago
Created attachment 331113 [details] [diff] [review]
(Av1) Add missing "$target_dir/" (Checkin: Comment 7)
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #331113 - Flags: review?(ted.mielczarek)
Comment on attachment 331113 [details] [diff] [review]
(Av1) Add missing "$target_dir/" (Checkin: Comment 7)

unofficial r+ from me, since I can't review in this module - that's exactly what I'd suggest.
Comment on attachment 331113 [details] [diff] [review]
(Av1) Add missing "$target_dir/" (Checkin: Comment 7)

You know, I think I hit this myself but couldn't see what was wrong. :)
Attachment #331113 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed

Comment 7

10 years ago
Comment on attachment 331113 [details] [diff] [review]
(Av1) Add missing "$target_dir/" (Checkin: Comment 7)

http://hg.mozilla.org/mozilla-central/index.cgi/rev/ab1246a64290
Attachment #331113 - Attachment description: (Av1) Add missing "$target_dir/" → (Av1) Add missing "$target_dir/" (Checkin: Comment 7)

Updated

10 years ago
Keywords: checkin-needed
per comment 7, -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008080208 SeaMonkey/2.0a1pre] (home, debug) (W2Ksp4)

V.Fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.