ABOOK: Non-ASCII mailing list name is not displayed correctly

VERIFIED FIXED in M18

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: marina, Assigned: m_kato)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-] [Need more info])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
**** observed with 2000-07-06 build ****
Steps to reproduce:
- select Personal Address Book;
- click on Mail List;
- create a new List using non-ascii chars in its name ( for ex :"Fírst");
- close the list and observe:
// on the left pane you can see "Fírst" but in the right pane you see only ascii 
chars till the point non-ascii chars begin "F"

Comment 1

18 years ago
Reassign to chuang.
Assignee: nhotta → chuang

Comment 2

18 years ago
nsbeta3 and M18
Keywords: nsbeta3
Target Milestone: --- → M18

Updated

18 years ago
Keywords: correctness

Comment 3

18 years ago
Japanese list names are displayed as dots.

Comment 4

18 years ago
*** Bug 47541 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Changed the summay accordingly.
Summary: Non-ascii chars are stripped from the list name → ABOOK: Non-ASCII mailing list name is not displayed correctly

Comment 6

18 years ago
Per i18n/mail triage meeting, this bug is classified as
nsbeta3-.

However, we would like to have more info on:

Whether or not using such a mailing list (the one with this
would have an effect on sending msgs. If we can send msgs to
the intended recipients with the defective Address list, then
this bug will stay nsbeta3-. If however, msgs cannot be sent or
some recipients may be missed, then we would have to reconsider
this bug for further triage. 
Sending to Xianglan for additional info.
QA Contact: momoi → ji
Whiteboard: [nsbeta3-] [Need more info]

Comment 7

17 years ago
Checked win32 2000-08-08-09-M18 build. Mails can be sent to the recipients
on a non-ASCII mailing list. But please note that the display problem not only
appears on Address Book main window, but also appears on mail compose window and 
list edit window.
(Assignee)

Comment 8

17 years ago
If you have no time, please assign to me.

Comment 9

17 years ago
Re-assigning to m_kato as requested. 
The mail team can use some help. 
kato-san, please assign it back to chuang 
if that ie necessary later.
Assignee: chuang → m_kato
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 10

17 years ago
Created attachment 14799 [details] [diff] [review]
a patch
(Assignee)

Comment 11

17 years ago
r=chuang@netscape.com
(Assignee)

Comment 12

17 years ago
check in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

17 years ago
verified as fixed in 2000-09-18-08 build
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.