"p" element within "table", "tr", "td" does not cause linebreak

RESOLVED INVALID

Status

P3
minor
RESOLVED INVALID
19 years ago
6 years ago

People

(Reporter: kleist, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Build ID: 2000070120

Please study the blue plate to the right. Under the heading "Zope news ..."
each news item is supposed to appear on its own line. This works fine in
Netscape 4.72, Opera 4.0, and IE 5.

Comment 1

19 years ago
Just remove the loose.dtd from the documenttype and it is parsed in compatib.
mode. The document is horrible html (validator.w3.org). So this bug is a doctype
issue. Marking as a duplicate.


*** This bug has been marked as a duplicate of 42388 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Created attachment 11103 [details]
Test Case - Missing </H2>

Comment 3

19 years ago
Created attachment 11104 [details]
Test Case - No Missing </H2>

Comment 4

19 years ago
This is not a DOCTYPE issue. This HTML has problems as the test cases show. I'm
reopening to mark invalid.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

19 years ago
Linux 2000070308.

There is several missing </h2>'s and thus the <h2> element continues on through
the table. http://validator.w3.org says this is invalid according to the DTD
being used. Mozilla should not correct for this behaviour, even if other
browsers think it's OK.

See test cases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID

Comment 6

19 years ago
Problem is, we removed those </H2> closing tags because Netscape CSS breaks on
them... and someone later added the DTD to conform at least partly to the W3C
speck. We'll look it over again.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.