Frame content is displayed twice

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Martin Horwath, Assigned: harishd)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][Fix in hand], URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The URL contains a frameset with 5 seperate frames. Every frame content is 
shown twice. This could be a hover error.

The error did not occure with M16
Testet with BuildID 2000070620 on WinNT (also noticed on Win95)

Comment 1

18 years ago
Pierre, can you please triage.
Assignee: clayton → pierre
(Reporter)

Comment 2

18 years ago
i have a little testcase for this problem.
i have a testcase for this.

it does not occure when i remove doctype, or the <noscript> tags.



(Reporter)

Comment 3

18 years ago
Created attachment 11285 [details]
my little testcase

Comment 4

18 years ago
Reproduced on the Mac too. This is a regression that occured between 07/06 and
07/12.

As in bug 44432:
- you need a doctype: loose or strict dtd, any doctype is fine.
- even empty tags can make a difference: NOSCRIPT here, MAP there.

I'm going to attach another testcase to show that the problem is not related to 
the stylesheet. If you LINK any dummy URL, like "file://foo", the bug happens 
too. Note that bug 44285 was reported recently about document.write() and LINKed 
stylesheet.

Reassigned to Parser/harishd like the other 2 bugs.
Assignee: pierre → harishd
Component: Layout → Parser
Keywords: regression
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Comment 5

18 years ago
Created attachment 11832 [details] [diff] [review]
Proposed patch [ fixes 44759,7670 ( strict dtd version ),45975 ]
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta3
Whiteboard: Fix in hand
(Assignee)

Comment 6

18 years ago
*** Bug 44432 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Marking nsbeta3+, given that we have a fix in hand and this is a relatively 
serious user experience problem.  This fix also fixes bug 7670 that enables 
NOSCRIPT content display when JS is disabled from the preferences.
Whiteboard: Fix in hand → [nsbeta3+][Fix in hand]

Comment 8

18 years ago
*** Bug 46740 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 45007 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
Fix is in. Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
This problem is no longer occuring. Verified in the Aug 24th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.