if encrypted connection is used brower is unable to send multipart/form-data to cups admin interface

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: leena.heino, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9.0.1) Gecko/2008071712 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9.0.1) Gecko/2008071712 Firefox/3.0.1

If https connection is used then browser won't send multipart/form-data to cups admin web-page. If continue is pressed in cups' admin interface when choosing a printer make, then browser just hangs and no data is sent to server. This was checked with Live Headers add on.

If ENCTYPE=multipart/form-data is removed from cups choose-make.tmpl and choose-model.tmpl then everything works normally. But ppd-file upload won't work.

Reproducible: Always

Steps to Reproduce:
1. Install cups.org printer spooler
2. Modify printer with https connection or create a new printer, in choose printer make press continue
3. Browsers hangs and no data is sent to server
Actual Results:  
Browser hangs and no data is sent to cups server

Expected Results:  
When I choose printer make I should be able to proceed to choosing printer model.

Cups admin interface worked in Firefox 2.0.14. It also works with IE7.
Is there a IE7 for sunos ?
Do you mean with "hang" that the application itself is frozen or do you mean that the form_submit is only not submitted ?
(Reporter)

Comment 2

10 years ago
You are right there is no IE7 for sunos, there was a IE 5.5. But I tested this in Windows with IE7 and Firefox 3.0.1 and in Solaris with Firefox 3.0.1 and Firefox 2.0.14.

Just Hangs, in this case, means that activity meter in the upper right corner just runs, and nothing happens. 

With live headers it seems that nothing is sent, but in the server I can see that only part of the multipart/form-data is received. The data sent seems to be missing a final boundary.
Is that a file upload or just a form ?
There is a change between FF2.x and FF3.x that you can not get the full path of a file with an File input, you get only the filename.

>If https connection is used
It works on a http connection ?

Someone else with CUPS could test this but I don't have CUPS on my win32 system, that's the reason why i ask .....

This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.