If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Blocklist service does not include plugin items for 3.1 alpha versions

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
--
major
RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: u88484, Assigned: reed)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
More often than not, Firefox locks up/freezes when opening a news article on from yahoo.com.  CPU is at 0 but Firefox is not responsive and have to kill Firefox via ctrl+alt+delete.  Disabling the Yahoo Application State Plugin version 1.0.0.5 fixes this.  Nominating for blocklisting this for Minefield especially since 3.1 alpha 1 is due soon.
Flags: wanted1.9.1?
Flags: blocking1.9.1?
(Reporter)

Updated

9 years ago
Severity: normal → major
stacktrace from the hang ?
(Reporter)

Comment 2

9 years ago
Doesn't crash, so no stacktrace.

Comment 3

9 years ago
This is my first time using WinDbg.  Here's what I got:

Break-in sent, waiting 30 seconds...
WARNING: Break-in timed out, suspending.
         This is usually caused by another thread holding the loader lock
(f54.cc8): Wake debugger - code 80000007 (first chance)
eax=101b9e2d ebx=00746240 ecx=00000000 edx=00000000 esi=00000078 edi=00000000
eip=7c90eb94 esp=00ffff2c ebp=00ffff90 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000246
ntdll!KiFastSystemCallRet:
7c90eb94 c3              ret
0:000> kp
ChildEBP RetAddr  
00ffff28 7c90e9c0 ntdll!KiFastSystemCallRet
00ffff2c 7c8025cb ntdll!ZwWaitForSingleObject+0xc
00ffff90 7c802532 kernel32!WaitForSingleObjectEx+0xa8
*** WARNING: Unable to verify checksum for C:\Documents and Settings\Brian Polidoro\Desktop\Copy of cairo\firefox\xul.dll
00ffffa4 101b9e40 kernel32!WaitForSingleObject+0x12
00ffffb4 7c80b683 xul!google_breakpad::ExceptionHandler::ExceptionHandlerThreadMain(void * lpParameter = 0x00000000)+0x13 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\toolkit\crashreporter\google-breakpad\src\client\windows\handler\exception_handler.cc @ 212]
00ffffec 00000000 kernel32!BaseThreadStart+0x37


The last module loaded is the Yahoo State Plugin:
ModLoad: 06600000 06612000   C:\Program Files\Yahoo!\Shared\npYState.dll

Comment 4

9 years ago
Yahoo State Plugin 1.0.0.5 is blocked (Bug 419127) so normal users would not see this problem.  I installed YM 9.0 beta with Yahoo State Plugin 1.0.0.7 and I get no hang.  
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

9 years ago
Well per the blocklist, it should be blocked in 3.0a1 and newer so why is this not blocked in 3.1a1?
Version: unspecified → Trunk

Comment 6

9 years ago
I asked myself the same question.  It is blocked in a new profile in 3.1a1.  So I guess it's an extension like Nightly Tester tools that's allowing it in my main profile.  
(Reporter)

Comment 7

9 years ago
With 3.1al and now 3.1a2pre I disabled Nightly Tester Tools and set 'extensions.checkCompatibility' to true but the yahoo application state plugin version 1.0.0.5 is still enabled and not blocked by the blocklist. Bug 421993 added this version to the blocklist and the webpage http://www.mozilla.com/en-US/blocklist/ and bug 421993#c40 state that it should be blocked for 3.0a1 and newer.
Blocks: 421993
Status: RESOLVED → REOPENED
Component: Plug-ins → Blocklisting
Flags: wanted1.9.1?
Flags: blocking1.9.1?
Product: Core → addons.mozilla.org
Resolution: WORKSFORME → ---
Summary: Firefox lockups/freezes/hangs on yahoo news articles (Yahoo Application State Plugin 1.0.0.5) → Yahoo Application State Plugin 1.0.0.5 not blocklisted in minefield
Version: Trunk → unspecified
(In reply to comment #7)
> With 3.1al and now 3.1a2pre I disabled Nightly Tester Tools and set
> 'extensions.checkCompatibility' to true but the yahoo application state plugin
> version 1.0.0.5 is still enabled and not blocked by the blocklist. Bug 421993
> added this version to the blocklist and the webpage
> http://www.mozilla.com/en-US/blocklist/ and bug 421993#c40 state that it should
> be blocked for 3.0a1 and newer.
> 

How long have you been using this profile. Have you disabled the blocklist? Does the profile folder have a blocklist.xml file in it?
(Reporter)

Updated

9 years ago
Flags: blocking-firefox3.1?
(Reporter)

Comment 9

9 years ago
Created attachment 331377 [details]
blocklist.xml

Probably about a year.  No I have not disabled it, all of the extensions.blocklist.* preferences are default.  I attached the file that was last updated just about an hour ago (07/25/2008 @ 7:30 PM EST)
(Reporter)

Comment 10

9 years ago
Created attachment 331378 [details]
Screenshot of settings and enabled extension
Ok the blocklist service isn't including plugin data for the alphas for some reason, compare:

https://addons.mozilla.org/blocklist/1/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/3.1a1pre
https://addons.mozilla.org/blocklist/1/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/3.0.1
(Reporter)

Comment 12

9 years ago
Yeah my 3.0.1 profile has the yahoo and quicktime parts in its blocklist.xml file but not my minefield profile.
Keywords: hang, regression
Summary: Yahoo Application State Plugin 1.0.0.5 not blocklisted in minefield → Blocklist service does not include plugin items for 3.1 alpha versions

Comment 13

9 years ago
That's strange.  I made a new profile and the Yahoo Plugin version 1.0.0.7 was blocked.  It's only supposed to block 1.0.0.5.  Is the block too general? In the profile that doesn't block that plugin this is what About:plugins has: 
File name: npYState.dll
Yahoo Application State Plugin version 1.0.0.7

How is something blocked if there's no blocklist yet in the profile?

Wait there's a blocklist in the program directory.  Which one takes precedence?  It seems like the one in the profile does.  Why is it in two places?
(In reply to comment #13)
> That's strange.  I made a new profile and the Yahoo Plugin version 1.0.0.7 was
> blocked.  It's only supposed to block 1.0.0.5.  Is the block too general? In
> the profile that doesn't block that plugin this is what About:plugins has: 
> File name: npYState.dll
> Yahoo Application State Plugin version 1.0.0.7

That is bug 446607

> How is something blocked if there's no blocklist yet in the profile?

Because of the blocklist in the program directory

> Wait there's a blocklist in the program directory.  Which one takes precedence?
>  It seems like the one in the profile does.  Why is it in two places?

Because when you first create a new profile, if it wasn't for the blocklist in the program directory you would be unprotected. The one in the profile takes precedence.
This looks like the database has max values of 3.0.* for these plugins.  This query needs to be run on the AMO database:
update blplugins set max = '3.*';

IT - could someone run  this query on the AMO prod DB?
Assignee: nobody → server-ops
Status: REOPENED → NEW
Component: Blocklisting → Server Operations: Web Content Push
Flags: blocking-firefox3.1?
Product: addons.mozilla.org → mozilla.org
QA Contact: plugins → mrz
Version: unspecified → other
(Assignee)

Updated

9 years ago
Assignee: server-ops → reed
(Assignee)

Comment 16

9 years ago
mysql> SELECT max FROM blplugins;
+-------+
| max   |
+-------+
| 3.0.* | 
| 3.0.* | 
+-------+
2 rows in set (0.00 sec)

mysql> update blplugins set max = '3.*';
Query OK, 2 rows affected (0.00 sec)
Rows matched: 2  Changed: 2  Warnings: 0

mysql> SELECT max FROM blplugins;
+-----+
| max |
+-----+
| 3.* | 
| 3.* | 
+-----+
2 rows in set (0.00 sec)
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.