Crash opening attachment w/unknown content types

VERIFIED FIXED

Status

defect
P3
critical
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: phil, Assigned: mscott)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][cut 8/29][nsbeta2-] relnote-userCrescendo 5.01)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Using 2000-07-06-09 commercial build on NT

1. Read mail message containing application/msword attachment
2 [details] [diff] [review]. Use menu to select attachment
3 [details] [diff] [review]. Get open/save dialog, choose open, ok
4. Get dialog asking to save (this is a separate bug, already filed)
5. Type name in Save File dialog box, ok
6. Boom

Stack trace coming up
(Reporter)

Comment 1

19 years ago
add keywords
(Reporter)

Comment 2

19 years ago
Posted file stack trace

Updated

19 years ago
QA Contact: lchiang → pmock
(Assignee)

Comment 3

19 years ago
Phil, what kind of attachment were you trying to open? (text, .eml, .doc, etc)
(Reporter)

Comment 4

19 years ago
.doc
(Assignee)

Comment 5

19 years ago
Ahh okay. I crash using the release build but not on my debug build. That's
because I have a fix for Bug #43661 in my tree. With that fix, you don't get the
2nd save as dialog because we properly detect the association between .doc and
msword so the document is really  opened.

If that bug gets plussed then this crash will be fixed in the common case.

Some investigation is still needed because I'm sure we could reproduce the crash
with an attahcment that has some whacking content type that the OS doesn't know
how to handle so it throws up another save as dialog.

re-assigning to me.
Assignee: rhp → mscott

Comment 6

19 years ago
Scott,

fyi, I've been testing today win & mac commercial builds 2000-070709-m17, I 
haven't been able to reproduce the crash on NT 4.0.  When I try to open a .doc 
document, it says it loading the file but fails to spawn/launch the Word 97 
application.  On Win98, it successfully launches the document in Word 2000.

On Mac, when I get the second dialog to save the attachment, I click on the save 
button but nothing get saved.

Comment 7

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Assignee)

Comment 8

19 years ago
I believe my fix for 43661 (which was checked in on Friday) minimizes the
frequency of this crash. We should only see it now when you try to open an
attachment with a content type your OS does not know how to handle.

This is less common then before the fix for 43661.

I still need to come up with a fix for this scenario to prevent you from seeing
the second save as dialog.

Estimated fix date: 7/20
Whiteboard: [nsbeta2+] → [nsbeta2+] Est. 7/20

Updated

19 years ago
Target Milestone: --- → M17
(Assignee)

Comment 9

19 years ago
Since I have this fixed for the most common cases I would not pull the beta off
the wire for this. I'm going to nominate it for a nsbeta2-.
(Assignee)

Comment 10

19 years ago
per my comments above and the mailnews beta2 triage meeting we just had, marking
nsbeta2-.
Keywords: nsbeta3
Whiteboard: [nsbeta2+] Est. 7/20 → [nsbeta2-] Est. 7/20
Target Milestone: M17 → M18

Updated

19 years ago
Keywords: relnote2

Updated

19 years ago
Keywords: mail2

Comment 11

19 years ago
removing "Est. 7/20" from status whiteboard since it's old status

+ per mail triage. Perhaps tied into bug 43574?
Whiteboard: [nsbeta2-] Est. 7/20 → [nsbeta3+][nsbeta2-]

Comment 12

19 years ago
P1 per mail triage.  Peter, you are able to see this crash in m18 when you try 
to open an attachment with a content type your OS does not know how to handle, 
as Scott says?
Priority: P3 → P1

Comment 13

19 years ago
I tried todays win32, macos, and linux builds.  Per mscott suggestions, I tried 
saving an attachment that content type is unknown by the operating system but I 
could not reproduce the crash. 

I renamed my test file from flash.xpi (associated with winzip) to flash.xpp.  
The file was sent from Communicator 4.74 with the type of 
"application/octet-stream;".  I could not reproduce the crash. :(
(Assignee)

Updated

19 years ago
Priority: P1 → P3
(Assignee)

Comment 14

19 years ago
I think this got marked with too high of a priority. The content types that we
know nothing about (not evening the OS knows about them) aren't many. I have
bigger fish to fry. Moving priority back to P3.

Comment 15

19 years ago
second pass: - per mail triage
Summary: Crash opening attachment → Crash opening attachment w/unknown content types
Whiteboard: [nsbeta3+][nsbeta2-] → [nsbeta3-][cut 8/29][nsbeta2-]

Updated

19 years ago
Keywords: relnote3, relnoteRTM

Comment 16

19 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2
Whiteboard: [nsbeta3-][cut 8/29][nsbeta2-] → [nsbeta3-][cut 8/29][nsbeta2-] relnote-user
(Assignee)

Comment 17

19 years ago
*** Bug 58862 has been marked as a duplicate of this bug. ***

Comment 18

19 years ago
My bug got marked dup of this.  I was on a consumer win98 machine that had MS
Works pre-installed instead of MS Word.  Not sure why the association failed,
when I open these in wordpad it can display them so it seems like my machine
should have done _something_ with it.

Adding kmurray to the cc.  Kevin, how likely is it that a large number of win98
users will have a configuration similar to mine?  How often to non-corporate
users mail doc files around?

Comment 19

19 years ago
We'd actually have to ping some PC OEMs to see what they're average config was 3
years ago. The closest thing we can do *now* is to see if Chrisn has any info on
config on the research site. cc:ing Chrisn.

Comment 20

19 years ago
Assign it to myself.
QA Contact: pmock → fenella

Comment 21

18 years ago
To Esther..
QA Contact: fenella → esther

Updated

18 years ago
Target Milestone: M18 → ---

Comment 22

18 years ago
No crash with build 2001030904 on win95.
Boris Zbarsky sent me a mail with a bogus content type.
I clicked on the attachment drop-down.
I clicked on the name of the file. A dialog pops up with "Open using" or "Save
to Disk".
A) Select "Open Using" and hit OK. Results : The file is saved in some temp dir,
then nothing happens
B) Select "Open Using" and choose any program, then hit OK. Results : The file
is correctly opened in the application (even if it can't read it).
Is there are bug for case A) yet?
In any case, no crash however much I try to mess with this.
(Assignee)

Comment 23

18 years ago
I've re-written how we open and save attachements in the current version of
mozilla. I'm pretty sure this crash has been fixed through that re-write. Let me
know if someone can still reproduce this.

Comment 24

18 years ago
Caused similar problem on build 2001092408 (opened email with attached word
document).  Crashes both release 0.9.4 and the nightly listed above on Linux.

Talkbacks for 2001092408: TB35810750W, TB35810091Q
(Assignee)

Comment 25

18 years ago
I'm going to re-mark this as fixed. This hasn't showed up again in any recent
talkback reports. I even searched for reports filed by Guy Hutchinson and turned
up nothing for this particular crash.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 26

18 years ago
removed item for this fixed bug from release notes.
Whiteboard: [nsbeta3-][cut 8/29][nsbeta2-] relnote-user → [nsbeta3-][cut 8/29][nsbeta2-] relnote-userCrescendo 5.01

Comment 27

18 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.