Closed Bug 447621 Opened 12 years ago Closed 12 years ago

All day event -> tooltip shows wrong date (start and end)

Categories

(Calendar :: Calendar Views, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: berend.cornelius09)

Details

(Keywords: regression)

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create an all day event
- check the tooltip

RESULT:
=======

- wrong date format -> Date: July 23 - 24, 2008

EXPECTED RESULT:
================

- Date: July 23, 2008

REPRODUCIBLE:
=============

- always
Flags: wanted-calendar0.9?
Attached patch patch v. #1Splinter Review
This is a regression from Bug 413103 – Unify and localize string building for time intervals [start + " - " + end]. I did not use my newly introduced function "formatItemInterval" at the dateFormatter here because the item was not right available. 
This patch changes this.
Attachment #330933 - Flags: review?(daniel.boelzle)
Attachment #330933 - Flags: review?(daniel.boelzle) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH
->FIXED
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Checked in lightning 2008072403 and sunbird 20080723 -> VERIFIED
Status: RESOLVED → VERIFIED
Flags: wanted-calendar0.9?
You need to log in before you can comment on or make changes to this bug.