click in print preview area doesn't get focus after toolbar gets focus - arrow scroll or PgDn PgUp don't work

RESOLVED WORKSFORME

Status

()

Core
Print Preview
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Timwi, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

STR

Reproducible: Always

Steps to Reproduce:
1. Open print preview.
2. Click on "Page Setup".
3. Click "Cancel".
4. Click on the page preview.
5. Try to use the cursor keys to navigate.
Actual Results:  
The click in step 4 doesn't do anything, so the cursor keys are ignored.

Expected Results:  
Clicking the print preview should give it focus so that the arrow keys can be used to scroll it.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → Trunk
It doesn't seem to work at all in Firefox 2, so no regression.

Updated

8 years ago
Duplicate of this bug: 528061

Comment 3

7 years ago
still occurs with current trunk 3. Click "Cancel" leaves focus in the toolbar and can't break out of it.
Summary: Print preview: Click doesn't focus → click in print preview area doesn't get focus after toolbar gets focus - arrow scroll or PgDn PgUp don't work

Comment 4

7 years ago
Don't seem to be able to reproduce in Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110827 Firefox/9.0a1 ID:20110827030801

Reporter -> Can you reproduce the issue with Firefox 6 or the latest nightly?

Comment 5

7 years ago
Also can't reproduce in Firefox 6. Must have been fixed since. The reporter told me he's OK with this being closed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.