Netstream buffer is too restrictive, should be larger to improve performance like in IE

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: smadayag.web, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Sorry for the IE reference, but it seems the netstream buffer could use bump in size to improve download performance.  Navigating to a flash intensive site can be slow.  On IE, because the buffer is larger, a flash intensive site is darn zippy.  Reference to IE is only for comparison and I must state, I do not use it personally.

Reproducible: Always

Steps to Reproduce:
Best way to reproduce is over a wireless connection:  Try with both IE and firefox browsers.

1.nav browser to:
http://www.playercore.com/users/qos/Final/Main-Final-TestPlan.html
2.select movie - H264 Trailers 720p
3.let it play
Actual Results:  
In IE - Playback is smooth and buffer is steady.
In Firefox - Buffer is sporadic and playback can be interrupted.

Expected Results:  
Firefox - Buffer should be steady and playback smooth, if netstream buffer would be increased.
The file is played with Flash and that means that the flash plugin creates a buffer.
All browsers are using the npapi plugin but not IE which is using ActiveX plugin.
And if you report a bug about a plugin always add the used Plugin version in the bug report.

marking invalid, there is no "netstream" buffer in Firefox, the flash plugin does prebuffering.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.