crash trying to save a download file

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Dirk Munk, Assigned: Gagan)

Tracking

({crash})

Trunk
DEC
OpenVMS
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; OpenVMS 0 Digital_Personal_WorkStation_; en-US;
m16) Gecko/20000610
BuildID:    2000061507

I was trying to download the OpenVMS apache webserver from compaq.com. Just
after the moment the progress screen came on, Mozilla crashed.

Reproducible: Always
Steps to Reproduce:
1.Try the download
2.
3.

This is the stack dump:

%SYSTEM-F-ACCVIO, access violation, reason mask=00, virtual address=000000000000
0000, PC=000000000059E67C, PS=0000001B
%TRACE-F-TRACEBACK, symbolic stack dump follows
image    module    routine             line      rel PC           abs PC
LIBXPCONNECT  XPCWRAPPEDJSCLASS  GetInterfaceName
43838 000000000000348C 000000000059E67C
LIBXPCONNECT  XPCWRAPPEDJSCLASS  CallMethod
43515 0000000000002A38 000000000059DC28
LIBXPCOM  XPTCSTUBS_OPENVMS_ALPHA  PrepareAndDispatch
10888 000000000000033C 0000000000362B1C
LIBXPCOM  STUBS  M64$$$CODE$             107 0000000000000050 0000000000361E10
LIBMOZXFER  NSSTREAMXFEROP  OnError                         ?                ?
LIBMOZXFER  NSSTREAMXFEROP  OnStartRequest
43946 0000000000002538 0000000003BC9748
LIBNECKO  NSHTTPRESPONSELISTENER  OnDataAvailable
51218 0000000000001F14 00000000014AFA14
LIBNECKO  NSASYNCSTREAMLISTENER  HandleEvent
25604 0000000000001DD0 000000000140D7C0
LIBNECKO  NSASYNCSTREAMLISTENER  HandlePLEvent
25296 0000000000000B54 000000000140C544
LIBXPCOM  PLEVENT  PL_HandleEvent      35085 0000000000000B58 0000000000345BB8
LIBXPCOM  PLEVENT  PL_ProcessPendingEvents
35030 0000000000000A50 0000000000345AB0
LIBXPCOM  NSEVENTQUEUE  ProcessPendingEvents
23887 0000000000001794 000000000033F7C4
LIBWIDGET_GTK  NSAPPSHELL  our_gdk_io_invoke
53106 00000000000008B4 0000000000D3A954
LIBGLIB  GMAIN  g_main_dispatch        19191 0000000000000AD0 0000000000E49E20
LIBGLIB  GMAIN  g_main_iterate         19412 000000000000128C 0000000000E4A5DC
LIBGLIB  GMAIN  g_main_run             19470 0000000000001470 0000000000E4A7C0
LIBGTK  GTKMAIN  gtk_main              20651 0000000000000A58 000000000109A508
LIBWIDGET_GTK  NSAPPSHELL  Run         53388 0000000000001490 0000000000D3B530
MOZILLA-BIN  NSAPPRUNNER  main1        62525 0000000000006300 0000000000036300
MOZILLA-BIN  NSAPPRUNNER  main         62711 0000000000006984 0000000000036984
MOZILLA-BIN  NSAPPRUNNER  __MAIN           0 0000000000000070 0000000000030070
MOZILLA-BIN                                0 000000000002EEB8 000000000003EEB8
PTHREAD$RTL                                0 000000000003115C 000000007BBFB15C
PTHREAD$RTL                                0 0000000000012B48 000000007BBDCB48
0 FFFFFFFF836DF3F4 FFFFFFFF836DF3F4
$

Comment 1

18 years ago
Reporter: please provide a URL where this can be tested, and also please test to
see if this still occurs on the latest nightly build. Several download bugs were
fixed around 7/5/2000.

Comment 2

18 years ago
->networking, cc colin but i bet this has been fixed since 6/15
Severity: major → critical
Component: Browser-General → Networking
Keywords: crash

Comment 3

18 years ago
reassign
Assignee: asa → gagan
QA Contact: doronr → tever

Comment 4

18 years ago
OpenVMS doesn't build nightlies, but I just tried downloading the Apache kit 
with my 7/4 code, and it worked just fine. So I believe this can be closed with 
a "fixed in M17".

The URL is case anyone wants to test is
http://www.openvms.digital.com/openvms/products/ips/apache/get_apache.html

Comment 5

18 years ago
resolving WFM per colin's comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.