Allow search bar to derive results from awesome location bar

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: johnh30024, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

The way I have always browsed was to go to the URL bar when I !knew an address. Whenever I needed to find something that I didn't know of (or shortcutting long urls, for forget them in this circumstance), I go to the search bar.

Even with all of the press about the awesomebar among elite technophile websites (websites aren't like tv...) who really knows about the awesomebar? How will anyone else on a local network with this preinstalled discover this? Many people have intuitively associated the search bar because of the search icon. They have used it for search.

Well you say, why not just search for sites, old history, or plain urls with the location bar?

Because right now FF does "i am lucky". And it seems not to change that so I'll try to change this....

===
Can the search bar also find old history items? Sure it might intrude google suggestions. But it could be more relavant..

Reproducible: Always
Component: History → Search
QA Contact: history → search
Version: unspecified → 3.0 Branch
We'll be moving away from the separate search bar in the future and I think trying to pack this all in to a popup already displaying form history and suggestions would crowd things a little too much.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.