Closed Bug 447791 Opened 14 years ago Closed 14 years ago

auto-complete dropdown menu does not appear on new tabs

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 424646

People

(Reporter: luke_cuthbertson, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Auto-complete dropdown menu does not appear under the text input field, as it would normally, once you start typing.

Occurs when:

1. A web page containing a form is your home page and you open a new tab. 

2. The text field automatically has focus (or does it?). In other words, the blinking line is present in the text field as soon as the page loads and the user can start typing straight away without using the mouse or tabbing. 

It does NOT occur when:

1. You open a new instance of FireFox, with a single tab opened by default on your home page.

2. You manually enter the URL, link from another page or refresh the page.

3. If you have to manually give the field focus or you click out of the field and back in again.


I have not tested if this occurs when one page opens another page in a new tab.


The prerequisites for creating the problem may sound artificial but if Google is your home page (as it is mine and probably many others) it is quite a common thing to want to do.

Reproducible: Always

Steps to Reproduce:
1. Set Google as your home page.
2. Go to Google, type in a string of characters and submit the form.
3. Open a new tab and start typing the first few characters of the previous string (do not click anywhere else).
Actual Results:  
Auto-complete dropdown that offers suggestions does not appear

Expected Results:  
Autocomplete dropdown that offers suggestions should appear. Refresh the page and try again to see expected result.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424646
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.