Closed Bug 447876 Opened 12 years ago Closed 12 years ago

FF 3.0 does not recognize the value 'invert' for the CSS 'outline-color' property.

Categories

(Firefox :: General, defect)

3.0 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 359497

People

(Reporter: bpage, Unassigned)

Details

(Keywords: css2)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Firefox 3.0 throws the an warning when parsing CSS containing the attribute outline-color with a value of 'invert'.

Error Console Output:
Warning: Expected color but found 'invert'.  Error in parsing value for property 'outline-color'.  Declaration dropped.
Source File: file:///D:/transfer/site/page.htm
Line: 9

Reproducible: Always

Steps to Reproduce:
View any page with this CSS defined.
Actual Results:  
The element is rendered without a visible outline.

Expected Results:  
outline-color is used to set the color of the outline of an element. Setting it to 'invert' ensures the outline is visible by performs a color inversion of the background.

This use to work in Firefox 2.0, but no longer works in Firefox 3.0.

This example code demonstrates the problem:

<html>
<head>
<style type="text/css" media="all">
body {
	background-color: #000;
	color: #fff;
}
div {
	outline-color: invert;
	outline-style: dotted;
	outline-width: 1px;
}
</style>
</head>
<body>
<div>test box</div>
</body>
</html>

Compare Firefox 3.0 to Firefox 2.0 or Opera to see the problem.
Severity: major → normal
Keywords: css2
Version: unspecified → 3.0 Branch
Summary: FF 3.0 does not recognize the value 'invert' for the CSS outline-color atttribute. → FF 3.0 does not recognize the value 'invert' for the CSS outline-color property.
Summary: FF 3.0 does not recognize the value 'invert' for the CSS outline-color property. → FF 3.0 does not recognize the value 'invert' for the CSS 'outline-color' property.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359497
You need to log in before you can comment on or make changes to this bug.